Composition opened by mailto: doesn't accept input at first

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: mozilla, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
2002073118 trunk

STEPS TO REPRODUCE:

1) Type "mailto:" in the URL bar and hit ENTER. A composition window pops up
with a caret blinking in the To: field.

2) Begin typing the address.

RESULT:

No keyboard input is accepted.

EXPECTED:

Typing should cause characters to be entered.

Comment 1

17 years ago
Seemes a focus problem.
-->varada
Assignee: ducarroz → varada
(Reporter)

Comment 3

17 years ago
WFM 2002080408 trunk. Tentatively marking WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

17 years ago
Reopening. See the problem again with 2002080614. Will leave open until it goes
away for a longer time.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
confirmed the bug in Mozilla 1.2b/WinXP BuildID 2002101612
Also happend in this kind of link:
mailto:test@example.com%28Foo%20Far%29?subject=foobar
The carret is left in the body and is blinking, but when you
type, nothing is accepted.
Is this a dupe? Or should I create a new bug?
taking all of varada's bugs.
Assignee: varada → sspitzer
Status: REOPENED → NEW

Comment 8

16 years ago
Testing with 1.3 Final.  Symptom listed is correct; however, if you leave the 
compose window open, return to the browser, refocus on the address bar with 
"mailto:" and hit return again, you get a new compose window with the focus in 
the To: spot, and accepting input.

I cannot duplicate Oliver Schulze L.'s symptom with 1.3 Final.  However, I poked 
around and found some interesting differences.

Given four different forms of mailto:
A1) "mailto:"
A2) "mailto:?subject=Yowza"
B) "mailto:foo@bar.com"
C) "mailto:foo@bar.com?subject=Yowza"

there are several differences to be found, depending on whether the URL is 
clicked as a link or entered into the address bar, and on whether it is 
activated with another mail compose window open or not.  (I did this testing 
with one browser window and the mail/news window open.)

A1) and A2) should put the focus on the To: field; both behave identically.
 - first and second click both have visible cursor and keyboard focus on To:
 - first addressbar, visible cursor is on To: but doesn't accept keys. 
(Activating another window, then the compose window again, text is accepted.)
 - second addressbar, visible cursor and keyboard focus on To:

B) should put the focus on the Subj: field.
 - first click, focus is on *body*, cursor sometimes visible, sometimes not
 - second click, visible cursor and keyboard focus on Subj:
 - first addressbar, browser takes back focus, but reactivating compose window, 
focus is on *body* (with visible cursor)
 - second addressbar, visible cursor and keyboard focus on Subj:

C) should put the focus on the body.
 - first click, focus is on body, cursor sometimes visible, sometimes not
 - second click, visible cursor and keyboard focus on body
 - first addressbar, browser takes back focus, but reactivating compose window, 
focus is on body (with visible cursor)
 - second addressbar, visible cursor and keyboard focus on body.

In every case, if there is a problem, it is when the compose window is the first 
compose window opened; the second compose window behaves flawlessly.

Opening the first window using the addressbar, the focus is not where it should 
be; either the focus is lost despite a blinking cursor (A1 & A2), or it's back 
at the browser (B & C).

Opening the first window with a click intermittently fails to display a cursor 
(B & C), but otherwise behaves OK.

Opening the first window with a URL including address but no subject puts the 
cursor on the body, rather than the Subj: line.

Comment 9

16 years ago
After all that testing in 1.3 Final, I have repeated all the tests with 1.4b 
(0426) and find that *all* of the problems I cited have been fixed.

Jerry Baker, can you confirm?  (Or would you rather wait for an official 1.4 
release?)
*** Bug 180774 has been marked as a duplicate of this bug. ***
Jerry Baker, can you confirm whether this bug has been fixed with the 1.4 Final 
release of Mozilla?
=>WFM, no response from reporter.
Status: NEW → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WORKSFORME
*** Bug 176796 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.