Closed Bug 1607021 Opened 2 years ago Closed 2 years ago

Endless change of modification dates in IMAP local files with Maildir

Categories

(MailNews Core :: Database, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: 85ta, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

I converted a GMX IMAP account to Maildir (= one .eml file per mail on my hard disk). I used Thunderbird 64 bit version 68.3.1 under Windows 10 64 bit.

Actual results:

Every time I open the IMAP folder (e. g. the inbox) in Thunderbird, ALL the .eml files stored locally get a new modified date!

Expected results:

This is very annoying for backups, since all files are filtered as "changed" and are saved again. This is what I wanted to avoid by switching to maildir.

Expected behaviour is: an existing .eml file keeps its modified date. Only new files need to be part of a backup process.

Component: Untriaged → Database
Product: Thunderbird → MailNews Core

I am sorry, I cannot reproduce this "error" anymore. Seems it came from compacting all folders in the converted account - which of course makes no sense.

Perhaps the option to "compact" a maildir account should be deactivated. But this would be a kind of a feature request, not a bug report.

Please excuse this report.

No longer blocks: maildirblockers
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.