CSS hover property for a <TD> breaks SELECT control

RESOLVED DUPLICATE of bug 154670

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 154670
16 years ago
16 years ago

People

(Reporter: Marc Jauvin, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020731
BuildID:    2002073104

The following HTML code shows that you cannot open the drop-down menu for the
SELECT control:

<html>
<head>
  <style type="text/css">
  <!--
  #myid:hover {cursor: crosshair;}
  //-->
  </style>
</head>

<body>
<h1 id=myid>
  <select>
    <option>1
    <option>2
    <option>3
    <option>4
  </select>
</h1>
</body>

</html>

Reproducible: Always
Steps to Reproduce:
1. create the HTML page with code from above
2. open the page you created
3. try to select an item in the list (SELECT control) 

Actual Results:  The drop-down menu does not show-up

Expected Results:  drop-down menu should open

Comment 1

16 years ago
WFM win98 2002080108

Comment 2

16 years ago
dupe of "drop-down select menu does not work with :hover"

*** This bug has been marked as a duplicate of 154670 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.