Closed Bug 16073 Opened 20 years ago Closed 20 years ago

crash: nsDocLoaderIMpl::FireOnEndDocumentLoad when quitting

Categories

(Core Graveyard :: Embedding: APIs, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Brade, Assigned: pierre)

Details

Run Apprunner
Open Editor from Task menu
Do some minimal editing to page (change font and type a few things)
Choose Quit from the File menu
<crash>

Partial stack trace includes:
 ...
 nsWebShell::Destroy
 nsWebShell::Stop
 nsDocLoaderImpl::Stop
 0x349984C (PPC) --> mLoadGroup->Cancel();
 nsDocLoaderImpl::OnStopRequest
 nsDocLoaderImpl::FireOnEndDocumentLoad
 0x42A7594C (PPC) --> FireOnEndDocumentLoad();

I'm not sure if I can reproduce this crasher or if it has been fixed already.
Assignee: nisheeth → pierre
Pierre, I tested this Windows and Unix today and could not replicate the crash.
Please test this on a Mac and mark this as a worksforme if you don't see the
crash.  Thanks.  I'm putting myself on the cc list and re-assigning this to you.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I tried with an optimized build fresh from this morning then with a 5-day old
debug build, both with Composer and Plaintext Editor, but I did not see the
crash. Marking Fixed (why don't we have the resolution of "Gone"?).
Status: RESOLVED → VERIFIED
I can't reproduce it anymore either; assume it was fixed.  Verified.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.