Closed Bug 1607477 Opened 6 months ago Closed 6 months ago

"Insert HTML" pane doesn't resize well

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set
normal

Tracking

(thunderbird_esr68 fixed, thunderbird73 fixed)

RESOLVED FIXED
Thunderbird 74.0
Tracking Status
thunderbird_esr68 --- fixed
thunderbird73 --- fixed

People

(Reporter: CarlPonder, Assigned: Paenglab)

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

I occasionally modify my messages in HTML directly, using the menu functions

  Edit -> Select All
  Insert -> HTML

These give me a (small) pane containing the HTML representation of the message, which I can edit directly.

Actual results:

That being said, the HTML pane is too small to give a good view of the bracketed HTML constructs. I can resize the pane horizontally and it gives a wider view. If I resize the pane vertically, however, it resizes the "dead" area of the pane rather than the edit-window, which is useless.

Expected results:

The edit-window of the Edit HTML pane should re-size both vertically & horizontally.

Comment on attachment 9119122 [details]
Screenshot from 2020-01-07 09-41-04.png

Note that the portion of the pane being re-sized doesn't add any new information, it's just wasted space.
For a longer message I *really* need to be able to see more of the contents of the edit window.

On a side-note, I end up editing the HTML is order to fix these cases:

  1. When I copy-paste a table from a LibreOffice spreadsheet, all the fonts in the whole message shrink to extra-small.
  2. When I indent the contents of a quotation, sometimes the quotation-bar moves over and sometimes it doesn't. I don't see any logic to the choice. But I can always fix it by interchanging the nested <blockquote ...> openings.
  3. When the last part of a message is a table, I can't click and add more text to the message. If I edit the HTML I can append a <br> at the end of it all, and use that as an insert-point for more text.

Arguably these should all get fixed in Thunderbird, but I'd be inclined to give higher priority to things I can't work around this easily.

I think it should be okay to add this styles directly, also because the vbox has already one.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9119150 - Flags: review?(mkmelin+mozilla)
Attachment #9119150 - Flags: approval-comm-beta?

Patch for ESR.

Attachment #9119151 - Flags: approval-comm-esr68?
Comment on attachment 9119150 [details] [diff] [review]
1607477-textarea-flex.patch

Review of attachment 9119150 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thx! r=mkmelin
Attachment #9119150 - Flags: review?(mkmelin+mozilla)
Attachment #9119150 - Flags: review+
Attachment #9119150 - Flags: approval-comm-beta?
Attachment #9119150 - Flags: approval-comm-beta+
Target Milestone: --- → Thunderbird 74.0

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/50bf5e8f6119
Fix resizing of "Insert HTML" window by adding a "flex: auto;" to the html:textarea. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED

Please supply a commit messages that tells us what the change is all about.

Attachment #9119151 - Flags: approval-comm-esr68? → approval-comm-esr68+

Hmm, somehow the C-C commit message was better.

You need to log in before you can comment on or make changes to this bug.