Closed Bug 1607498 Opened 3 years ago Closed 3 months ago

about dialog's restart to update button does not get re-added if the restart is cancelled by the user (e.g. via onbeforeunload dialogs)

Categories

(Toolkit :: Application Update, defect, P3)

71 Branch
defect

Tracking

()

RESOLVED FIXED
102 Branch
Tracking Status
firefox102 --- fixed

People

(Reporter: ptrpl4, Assigned: standard8)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

  1. you need 1 tab with "closing checking"
    (if you didn't save last changes and click "close tab" or "update browser" - browser show alert "close tab or not") my example - https://app.gitbook.com
  2. start update process from "about window:
  3. you will see alert from tab from point 1
  4. click in alert window "i don't want restart browser now"

Actual results:

browser still working - its ok
but i cant start again restart process from "about" window
i see infinity waiting for restart (screenshot)

Expected results:

i want to see restart button on "about" page again
and have ability to start process again

Hi ptrpl4,
Unfortunately, I don't have a GitBook account to use the mentioned example.
Could you specify how did you manage to trigger the about window while the "Exit and close tabs?" window is displayed? [step 2]
On Windows 10, other interactions with the browser UI is not possible while that window is toggled, I will check this out on MacOS too tomorrow but maybe you can clarify that in the meantime.

Flags: needinfo?(ptrpl4)
Flags: needinfo?(ptrpl4)

Seems that it is specific to the dialogs created by pages. Is this reproducible without any addons installed?
Moving this over to a component in the meantime.

Component: Untriaged → General
Flags: needinfo?(ptrpl4)

i found!
you can reproduce it on any page on wikipedia.org

  1. open any article
  2. click edit
  3. do some changes (do not save changes!)
  4. open "about" and click update
  5. you will see alert from page - close alert
  6. open about window again

p.s.
already checked it on windows

Flags: needinfo?(ptrpl4)

Hmm, grab the about window when it is stuck in that "Restarting..." loop and move it down. You will see that the "Leave this Page" prompt from wikipedia is actually displayed behind it.
If you choose to "Leave this page" Firefox will update and restart.

Is this also happening in your case?

Flags: needinfo?(ptrpl4)

yes. i know, if i choose "leave" page option - browser will update and its ok

my point - if i choose another option and want to "stay" on page, then i will see infinite "restarting" on "about" page. This looks not right.
I think right logic - i will see "restart and update browser" button again

Flags: needinfo?(ptrpl4)

The priority flag is not set for this bug.
:Dolske, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dolske)
Component: General → Application Update
Flags: needinfo?(dolske)
Product: Firefox → Toolkit
Summary: user can't continue update process after system warning → about dialog's restart to update button does not get re-added if the restart is cancelled by the user (e.g. via onbeforeunload dialogs)

Reproducible for me using the STR from comment 4 (thank you for providing an easy test case!).

Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Duplicate of this bug: 1605618
Assignee: nobody → standard8
Status: NEW → ASSIGNED

Comment on attachment 9277351 [details]
Bug 1607498 - If an update via the about dialog is cancelled due to staying on a page, ensure the dialog is reset to the apply state. r?bytesized

Revision D146805 was moved to bug 1739977. Setting attachment 9277351 [details] to obsolete.

Attachment #9277351 - Attachment is obsolete: true
Attachment #9277351 - Attachment is obsolete: false
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c1c3545f1e49
If an update via the about dialog is cancelled due to staying on a page, ensure the dialog is reset to the apply state. r=application-update-reviewers,bytesized
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 102 Branch
You need to log in before you can comment on or make changes to this bug.