Character coding change should be available from context menu

REOPENED
Assigned to

Status

()

REOPENED
16 years ago
7 years ago

People

(Reporter: serhunt, Assigned: rogerio.rag)

Tracking

({uiwanted})

Trunk
x86
Windows XP
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1) Gecko/20020726
Netscape/7.0

I apologize if this is a known bug, but quick search of the component did not
reveal anything related.

Sometimes you need to change the char set on the page but the main menu is not
available. This often happens with pop-ups when they don't display the usual
chrome. There is no way to get the page readable in such a situation. Right
mouse button click seems to be a reasonable solution.

Here is an example:
1. go to http://24.83.32.98/RusCDCovers/vcd.htm , note that the char set needs
to be changed, this is easy to do from the main menu
2. click on any letter in the list which is clickable, a JS window pops up
3. note that you again need to change the char set to make it readable

Actual  : no way to do that, since the window lacks the main menu
Expected: context menu should allow to change the character coding

Comment 1

16 years ago
ruixu: i believe this is a dup.  I just don't remember which.

Comment 2

16 years ago
a dup of bug 122507 ?
Keywords: intl
QA Contact: ruixu → ylong

Comment 3

16 years ago
bug 155509 is filed for change charset by right click mouse, and it marked as
dup of bug 98395 which is requested for change charset seperately.

I think fix bug 98395 should resolve this problem here too.
(Reporter)

Comment 4

16 years ago
Looks like it will. But I think bug 98395 is about more complicated issue:
having different encodings in different frames and not necesseraly about
possibility to switch encoding with context menu although it is discussed there.
Maybe it would make sense to separate the different issues in different bugs?

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 5

15 years ago
*** Bug 239244 has been marked as a duplicate of this bug. ***
QA Contact: amyy → i18n
This is Firefox UX issue.  They should handle this and decides whether this function is needed.

Also, whether there is encoding menu in context menu.
IE ... Yes
Chrome ... No
Safari ... No
Opera ... No
Assignee: tetsuroy → nobody
Status: ASSIGNED → NEW
Component: Internationalization → Menus
Product: Core → Firefox
QA Contact: i18n → menus

Comment 7

7 years ago
Of course this feature is needed, to navigate 3 menus to change encoding is **** retarded. And we don't care what browsers with minor market share have or have not in their menus, this function should be on the fingertips!

Comment 8

7 years ago
Also the corresponding button for message header area is desired.
Assignee: nobody → rogerio.rag
(Assignee)

Updated

7 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

7 years ago
Created attachment 583916 [details] [diff] [review]
Patch to this bug.
Attachment #583916 - Flags: review?
I don't think we want to fix this bug as it is summarized. Needing to change the encoding isn't something that the majority of users need to do on a regular basis, and so having the option in the context menu just makes the menu harder to use for other more common tasks.

For users on Windows, it's already possible to change the encoding in popups by using the entry in the Firefox button menu, and for users on Mac the menu is always visible anyways.

Thanks for jumping in and working on a patch, Rogério, but I don't think we want to fix this, so I'm going to mark this WONTFIX.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Comment 11

7 years ago
Who the **** are you to decide what users need to do or not? We had enough of you ignorant amerikans spoiling everything, and now you have a desire to **** on Free software too? It IS the glaring bug, stuck your arrogance up and fix it.

Comment 12

7 years ago
Gavin, I would like to put my opinion as a non english user. As my language uses accentuation (Portuguese pt-BR), when the browser opens a popup window there are moments when the character encondig is not correct. It would be easier to have the option to change it at the mouse context menu.
If you use english, this really not matters, but for users of other languages, I think this may be very interesting.
To be clear, I am aware of the value of the charset menu for users in certain non-en-US locales.

I was wrong in comment 10 - the Firefox menu doesn't appear in popup windows on Linux/Windows.

I still don't think that adding the charset menu to the context menu is the ideal solution, but it's hard to identify a good alternative design. It may be feasible to do it only for popup windows.
Status: RESOLVED → REOPENED
Keywords: intl → uiwanted
Resolution: WONTFIX → ---

Comment 14

7 years ago
I belong to the others 90% of world that do not use English as official language.
I have used Firefox since its early versions and when I'm accessing some sites, mainly government sites or others web systems, I receive some pages with encoding problems. Then, I use the menu bar to change page encoding. An option in context menu would help me a lot on these situations.
You need to log in before you can comment on or make changes to this bug.