change view source shortcut from cmd-E to cmd-U or Cmd-Opt-V

VERIFIED FIXED in Camino0.8

Status

--
enhancement
VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: mikepinkerton)

Tracking

({access})

unspecified
Camino0.8
PowerPC
Mac OS X
access

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
cmd-E is used for view source in IE, but should we follow the mozilla convention
and use cmd-U instead?
(Reporter)

Updated

16 years ago
Keywords: access
QA Contact: winnie → sairuh

Comment 1

16 years ago
This is requesting the same thing as bug 157051, but for different reasons. Note
that while I commented that 157051 should be closed because command-E is _not_ a
reserved combination, I have no objection to changing the shortcut for
ease-of-use reasons.

Right now, the view source command is command-E in IE, command-U in Moz, and
shift-command-V in OmniWeb. It is difficult to map this shortcut to something
intuitive, since V, P and S are all reserved so we can't use any capital letters
of the command name, "View Page Source." OmniWeb's use of shift-command-V is
also a bad solution, not only because it is three keys (which might not really
be a problem, since this is a relatively infrequently used command), but because
shift key shortcuts are supposed to complement their command key shortcut, and
View Source has nothing to do with Paste.

Looking at the letters in the command that aren't reserved or  recommended in
the context of a browser, we have **e* ***e **ur*e. In text editing
applicaitons, command-U is underline, and we are likely to have more users
migrating from IE thatn from Moz, so the current mapping seems logical to me.

Comment 2

16 years ago
IMO we should stick with the IE convention, since that is what most of the
Chimera users will have been using already.
(Reporter)

Comment 3

16 years ago
feel free to wontfix this...

Comment 4

16 years ago
*** Bug 157051 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
Personally, I don't think we do have to use letters that occur in the text 
"View Source" for the shortcut. Seriously, if you try to remember the 
shortcut for this, will you think "Oh maybe it is E because an E occurs in 
View Source" ? Certainly not, the same holds for U.

I admit that Cmd-E offers itself kind off since it is used in IE which is the 
dominant browser on Mac OS X. However, Cmd-E is used in a big lot of 
other applications for the same thing (Enter string into the find dialog):
 *any Cocoa application that uses the Find menu from the InterfaceBuilder 
palette: TextEdit, Terminal.app, Mail.app, ProjectBuilder, InterfaceBuilder,  
to name a few
* BBEdit
* CodeWarrior
* OmniWeb

And I think this number will grow as more applications adapt to this. We 
already have a patch on bug #160771 that implements a better "Find" 
interface similiar to other Cocoa apps (and sharing the find string with 
them! a very essential feature for me, I wish BBEdit would support it).

Faced with the decision of trying to be compatible with many applications, 
and one (albeit important) application, my choice is clear. :-)

Comment 6

16 years ago
Yes, I suggested that we use command-U for view source if we actually have the
Use Selection for Find command mapped to command-E; I was just saying that we
shouldn't do things just to be like Mozilla if there isn't a good reason why
Mozilla is doing them.
(Reporter)

Updated

16 years ago
Component: General → Accessibility

Comment 7

16 years ago
What if both Cmd+E and Cmd+U worked? can you not have to keyboard shortcuts that
do the same thing? 

Other apps with shortcuts:
* Mail.app uses Option+Cmd+U for View Source and Cmd+E for Use Selection for Find.
* Safari uses Option+Cmd+V for View Source and Cmd+E for Use Selection for Find.

Since Apple is the authority on HI, maybe we should align with them instead of
IE (remember who makes it).

But for the record, I am voting that it be changed to Cmd+U.

Comment 8

16 years ago
According to Apple's Human Interface Guidelines, command-E is the preferred key
combination for entering the current selection into find. People are, for the
most part, used to this behavior since basically all Apple apps function like
this. The lone exception is IE, which is certainly not a poster child for good
UI design.

Comment 9

16 years ago
*if* this keystroke is going to change I would prefer to see it moved to using V
instead of E as that would better align it with other OS X browsers. I just
don't see a big draw in making it behave like mozilla. Only problem is it
appears Safari and OmniWeb are a bit conflicted as to which modifier keys are
used (if i had to say i prefer safari here... both cause its easier to hit with
my fat thumbs and for the reasons already stated)

Comment 10

16 years ago
I think we should go with Safari. Opt-Cmd-V
(Assignee)

Comment 11

15 years ago
will do.
Assignee: saari → pinkerton
Target Milestone: --- → Camino0.8

Comment 12

15 years ago
Created attachment 130340 [details]
Modified MainMenu.nib for Opt-Cmd-V keystroke.

Modified MainMenu.nib which now uses the (Safari like) Opt-Cmd-V keystroke to
show sourrce.

Comment 13

15 years ago
I certainly don't want to lengthen this relativly unimportant bug discussion,
but as already has been mentioned, don't mix command key meanings by using other
modifiers! This is certainly bad UI style and as long as we are not short on
keys we shouldn't do this. I'd vote for cmd-U instead.

I have a many other issues with key combos in Camino, I guess I'd better file
another bug/enhancement report for that (hoping that someone will look at it).
(Assignee)

Comment 14

15 years ago
martin, why are you so opposed to the safari keystroke? where in the HIG does it
say we should steer clear of modifiers for functions that aren't used that often?

Comment 15

15 years ago
To Mike: If you look at the standard keystrokes (Q, X, C, V, P) in my opinion
any combinations with modifier keys and those keystrokes should have a similar
meaning than the "original" keystroke. For instance, any combination with V
should lead to some kind of paste-operation (paste without quoting, without
styles...). I guess noone would come up with Command-Option-Q for doing
something else besides quitting (perhaps without asking whether you really want
to quit, which would be a nice feature if Camino did that when more than one
window or tab is open).

Comment 16

15 years ago
I don't agree with Martin. I think we should change it. Especially since I want
to implement Use Selection for Find and that just has to be Cmd-E...

Updated

15 years ago
Summary: change view source shortcut from cmd-E to cmd-U? → change view source shortcut from cmd-E to cmd-U or Cmd-Opt-V

Comment 17

15 years ago
Okay, to follow the lines of good cocoa applications this is perfectly
reasonable. My previous statement still applies - don't use key combos which
involve the standard set. command-u would be fine with me, at least it matches
Mozilla - I don't care about Safari (the last few times I started it, I only did
to check functionality ;-).
(Assignee)

Comment 18

15 years ago
changed to cmd-opt-v. we should implement set search string as cmd-e at some
point (another bug).
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 19

14 years ago
looks good in recent nightlies (for a long time).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.