Closed Bug 1607882 Opened 1 year ago Closed 1 year ago

Double clicking the picture-in-picture popout doesn't send it to fullscreen

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

71 Branch
x86_64
All
defect

Tracking

()

VERIFIED FIXED
mozilla76
Tracking Status
relnote-firefox --- 76+
firefox-esr68 --- unaffected
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- verified

People

(Reporter: f.smulders, Assigned: mconley)

References

(Depends on 1 open bug, Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0

Steps to reproduce:

Open any site that has a PiP-able video
Open the popout
Double click somewhere on the popou

Actual results:

Video stays playing, doesn't go fullscreen

Expected results:

Video should stay playing, but go to fullscreen view

OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Version: 56 Branch → 73 Branch
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Video/Audio Controls
Ever confirmed: true
Product: Firefox → Toolkit
Regressed by: 1543027
Version: 73 Branch → 71 Branch
Priority: -- → P3
OS: Windows 10 → All
Assignee: nobody → mconley
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5deeb2644977
Make double-clicking the Picture-in-Picture fullscreen the player. r=mstriemer

The problem appears to be that we can't fullscreen a window that has alwaysontop set on it on Linux GTK.

Hey Martin, would it make sense to stash the initial alwaysontop state, then set gtk_window_set_keep_above to FALSE before attempting to go to fullscreen, and then revert to the original alwaysontop state once fullscreen exits? Or is there a better way to do this?

Flags: needinfo?(mconley) → needinfo?(stransky)

(In reply to Mike Conley (:mconley) (:⚙️) from comment #6)

The problem appears to be that we can't fullscreen a window that has alwaysontop set on it on Linux GTK.

Hey Martin, would it make sense to stash the initial alwaysontop state, then set gtk_window_set_keep_above to FALSE before attempting to go to fullscreen, and then revert to the original alwaysontop state once fullscreen exits? Or is there a better way to do this?

Yes, that makes sense.

Flags: needinfo?(stransky)
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/24ad9eab9212
Picture-in-Picture windows should be able to enter fullscreen on Linux GTK. r=stransky
https://hg.mozilla.org/integration/autoland/rev/cb979a1c473f
Make double-clicking the Picture-in-Picture fullscreen the player. r=mstriemer
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Depends on: 1622544
Depends on: 1622547

Mike, maybe worth a mention in nightly release notes?

Flags: needinfo?(mconley)

(In reply to Pascal Chevrel:pascalc from comment #11)

Mike, maybe worth a mention in nightly release notes?

Yes, for sure! Should I write one, or what's the procedure for that?

Flags: needinfo?(mconley) → needinfo?(pascalc)

(In reply to Mike Conley (:mconley) (:⚙️) from comment #12)

(In reply to Pascal Chevrel:pascalc from comment #11)

Mike, maybe worth a mention in nightly release notes?

Yes, for sure! Should I write one, or what's the procedure for that?

Yes write one via the release notes form in Bugzilla https://wiki.mozilla.org/Release_Management/Release_Notes#How_to_nominate_a_bug_for_release_notes_addition.3F

Flags: needinfo?(pascalc)

Release Note Request (optional, but appreciated)
[Why is this notable]:

Gives users an often-requested enhancement to the Picture-in-Picture feature on desktop.

[Affects Firefox for Android]:

No.

[Suggested wording]:

Double-clicking on the Picture-in-Picture player window now puts it in fullscreen mode.

[Links (documentation, blog post, etc)]:

https://support.mozilla.org/en-US/kb/about-picture-picture-firefox

relnote-firefox: --- → ?

Thanks, note added to 76 nightly release notes.

Regressions: 1622391
Flags: qe-verify+

Confirmed issue with 74.0a1 (2020-01-08) on Windows 10.
Fix verified with 76.0b6 on Windows 10, macOS 10.15.3, Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Hi Mike! QA is thinking about conducting a final sanity check for this fix since it's in a user-facing area.

Apart from our regular picture-in-picture regression tests, is there anything in particular that you think we should focus on during our second pass?

Flags: needinfo?(mconley)

(In reply to Andrei Vaida [:avaida] from comment #17)

Apart from our regular picture-in-picture regression tests, is there anything in particular that you think we should focus on during our second pass?

Hi Andrei,

No, I can't think of anything extra to cover, beyond verifying the bugs that were fixed.

Flags: needinfo?(mconley)
You need to log in before you can comment on or make changes to this bug.