Closed Bug 1607899 Opened 5 years ago Closed 5 years ago

Video from Twitter is jittery when played back fullscreen

Categories

(Core :: Audio/Video: Playback, defect, P5)

72 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1608485

People

(Reporter: mkaply, Unassigned)

Details

Attachments

(1 file)

When playing video from this URL full screen on my Windows machine, it's jittery.

I only see this with twitter videos. Video of problem here:

https://photos.google.com/share/AF1QipNVIbJdt5fBBwbZ7AeBsu9m-yjNsjdDrRXKFGT2-RpQhLKzb3lPsmGPBKa0oZqNlA?key=WDM4dG0wMDRIdDZyRDIxU2N2NUNHU1BsVkN5bWxn

(you have to click the video to see the whole video)

Mike, thanks for the report, can you attach the about:support of the machine where you see the problem here?

Flags: needinfo?(mozilla)
Attached file about:support

Resolution is 3840x2160

Flags: needinfo?(mozilla)

I see:

Failure Log
(#0) Error: WMF VPX video decoding is disabled due to a previous crash.
(#1): CP+[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.

This means you're back to software decoding. I don't know why that is however.

Also I noticed your screen is running at 29Hz which is not super usual, we might have a bug lurking there.

jya, do you know if those errors could be the cause for this? How an we retry hw decoding?

Flags: needinfo?(jyavenard)

(In reply to Paul Adenot (:padenot) from comment #5)

I see:

Failure Log
(#0) Error: WMF VPX video decoding is disabled due to a previous crash.
(#1): CP+[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.

This only impacts the VP9 hardware decoder. AFAIK, Twitter doesn't use VP9 for their videos.

What it does suggest however is that the OP is using a Windows N or KN edition (used in Europe and Korea) and an out of sync Windows Media Feature Pack.

Mike, could you please provide more information about which version of windows you are using, if you have installed Windows Media Feature Pack and which version are you running if so.

Also I noticed your screen is running at 29Hz which is not super usual, we might have a bug lurking there.
Yes, this will lead to awful playback as frames will need to be dropped.

jya, do you know if those errors could be the cause for this? How an we retry hw decoding?

it gets retried whenever drivers are updated or Firefox version changes.

Flags: needinfo?(jyavenard) → needinfo?(mozilla)

It's standard Windows Pro (US English)
Version 1809 (OS Build 17763.914)

No Windows Media Feature pack

Flags: needinfo?(mozilla)

Is it possible this is a composition/painting/scaling issue rather than decoding as it's present only in full screen? Mike, would you be able to capture a profile run to see if that shows up anything?

Flags: needinfo?(mozilla)

Can you set your screen back to 60Hz ?

I only have 23,24,25,29,30 available in settings.

Flags: needinfo?(mozilla)

If I lower my resolution from 3840x2160 to 1920x1080, it doesn't happen.

Even just going to 2560x2440 is a lot better (occasional jumps).

I don't have this problem with Youtube videos or any other videos. Just mainly twitter videos.

What's the easiest way to get a profile in this case?

Priority: -- → P5

Could you use the Firefox Profiler and set the captured threads to * (to capture all threads)?

Try setting gfx.direct3d11.use-double-buffering to false in about:config.

If this is limited to h264 like comment 6 suggests it may help with Bug 1608485.

Flipping the pref (and restarting Firefox) fixes it. Should we dupe one to the other? Do you still want me to profile?

https://perfht.ml/36W4Qp7

No idea if this is correct. There was no place for a * for the captured threads. I just checked all the boxes.

I guess I was supposed to save it somehow, so that doesn't work. Still working on it.

If the issue is resolved by double buffering I think further profile runs are not needed. In case it's useful in future, for the * for threads, there should be an 'add custom threads by name' text box IIRC.

I will dupe this into the other bug as this appears graphics related and there is already more graphics specific discussion there.

Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: