Closed Bug 1608219 Opened 1 year ago Closed 1 year ago

linux64/debug mochitest-devtools-chrome often exceeds its max-run-time: devtools/client/webconsole/test/browser/browser.ini runs for too long

Categories

(DevTools :: Console, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1603765

People

(Reporter: gbrown, Assigned: gbrown)

References

(Blocks 1 open bug)

Details

Today, there are numerous test task timeouts reported in bug 1411358 for linux64/debug mochitest-devtools-chrome-12 (dt12): That test chunk is running for 90+ minutes. Other test chunks in the series run for only 20 or 30 minutes, but the test chunk algorithm cannot break down chunk 12 any further: it only runs one manifest, the devtools/client/webconsole tests.

https://treeherder.mozilla.org/logviewer.html#?job_id=284223033&repo=autoland
https://treeherder.mozilla.org/logviewer.html#?job_id=284221759&repo=autoland
https://treeherder.mozilla.org/logviewer.html#?job_id=284219443&repo=autoland

:nchevobbe - It looks like you are familiar with devtools/client/webconsole/test/browser/browser.ini tests. Would it be possible/reasonable to break up that test manifest into 2 or more smaller manifests?

Flags: needinfo?(nchevobbe)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Console

Sure, I already have a WIP patch for Bug 1603765 which does that.

Flags: needinfo?(nchevobbe)
Priority: -- → P3

Perfect! This is running fine now.

Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1603765
You need to log in before you can comment on or make changes to this bug.