If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla/Gecko Windows XP User Agents should differ for Home & Pro Editions

VERIFIED WONTFIX

Status

()

Core
Networking: HTTP
--
enhancement
VERIFIED WONTFIX
15 years ago
15 years ago

People

(Reporter: Joshua Holman, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
When an Windows XP user browses over the Internet with Mozilla or any other 
Gecko browser, this user agent is used:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020611

As you can see, the OS is listed as Windows NT 5.1 (XP) with no reference as 
to the edition of XP the user is using. I am suggesting that Mozilla's user 
agents for XP be updated to refect what edition of XP the user is using. For 
the Home Edition, the UA could be thus:

Mozilla/5.0 (Windows; U; Windows NT 5.1-H; en-US; rv:1.1a) Gecko/20020611

and for Pro:

Mozilla/5.0 (Windows; U; Windows NT 5.1-P; en-US; rv:1.1a) Gecko/20020611

This change would cut the work out for webmasters trying to figure out what 
kind of user is coming to the page. I see no privacy problems with the change. 
That is because it's pretty much known there are two editions of XP. I believe 
this change will make Mozilla a better product.
(Reporter)

Updated

15 years ago
Target Milestone: --- → Future

Comment 1

15 years ago
And what would be the advantage of this? Home and Pro are basically the same
product, just packaged differently (licenses, included apps, etc ...). I don't
see what the advantage could be for a webmaster.

Comment 2

15 years ago
XP is NT kernel version 5.1. The User Agent is right. Just 
Run --> winver
and you see NT 5.1 right ?
I'm not even sure, if there's _any_ way to detect this.. At least even MSIE only
says "Windows NT 5.1"
-> wontfix

We use the OS String and there is no difference the OS has the same string on
Home or Pro
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
as I expected to be honest
Status: RESOLVED → VERIFIED
i mean :
We use the OS String and the OS has the same string on
Home or Pro.
We also don't include the Service Pack level...

Target Milestone: Future → ---
(Reporter)

Comment 7

15 years ago
I think ALL browsers (Mozilla & Gecko inculded) ID Win XP as NT 5.1. Opera IDs 
the OS as XP. 
You need to log in before you can comment on or make changes to this bug.