Crash on page load [favicon]

VERIFIED DUPLICATE of bug 151154

Status

Core Graveyard
Image: Painting
--
critical
VERIFIED DUPLICATE of bug 151154
16 years ago
9 years ago

People

(Reporter: Mark Williamson, Assigned: Stuart Parmenter)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
See:

TB8940253G
TB8940183E
TB8940158H

Comment 1

16 years ago
WFM, current CVS, linux (minus fix for bug 157123)
Reporter: Please always include build ID in bug-reports.

Comment 2

16 years ago
   Reporter: could you please  read  the  Bug  Writing  Guidelines  at
http://www.mozilla.org/quality/bug-writing-guidelines.html to see  the
kinds of information we need in a bug report. Please report back  with
more information (like BuildID and steps to reproduce)  after  reading
those guidelines and consider using  the  Bugzilla  Helper  to  report
future bugs.

   The Helper can be found at
   http://www.mozilla.org/quality/help/bug-form.html
   Thanks for your help in testing Mozilla.
Keywords: crash

Comment 3

16 years ago
CONFIRMED on WinXP/2002080108.

Mozilla just silently closes. Gonna investigate.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: stackwanted
(Reporter)

Comment 4

16 years ago
Sorry, missing build info is as follows

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721

Steps to reproduce:

1) Goto URL http://www.buntingford.com
2) Observe crash

Comment 5

16 years ago
Figured it out. Mozilla crashes trying to display Buntingford's icon in the
title bar:

<link REL="SHORTCUT ICON" href="http://www.Buntingford.com/favicon.ico">

The icon is 31 x 39 x 8bit, if that helps any.
Summary: Carsh on page load → Crash on page load

Comment 6

16 years ago
Created attachment 93841 [details]
Icon that causes crash when placed in titlebar

Also crashes on 2002080119/win98se.

IE6.0 is unable to recognize this "icon" as well and shows the usual "IE
bookmark" icon in its titlebar. Mozilla tries to display this icon and crashes.


So we have two issues here.

2) Evangelism -- tell buttingford how to make/use icons.
1) Fix the crash -- the icon is bad, but it's no good reason to crash.
gfxImageFrame::SetImageData(gfxImageFrame * const 0x05193580, const unsigned
char * 0x051a7c70, unsigned int 96, int 3168) line 286 + 25 bytes
nsICODecoder::SetImageData() line 109 + 47 bytes
nsICODecoder::Flush(nsICODecoder * const 0x051933e0) line 189
imgRequest::OnStopRequest(imgRequest * const 0x03c60a70, nsIRequest *
0x03c602c0, nsISupports * 0x00000000, unsigned int 0) line 636
ProxyListener::OnStopRequest(ProxyListener * const 0x03c60b48, nsIRequest *
0x03c602c0, nsISupports * 0x00000000, unsigned int 0) line 707
nsStreamListenerTee::OnStopRequest(nsStreamListenerTee * const 0x0518b038,
nsIRequest * 0x03c602c0, nsISupports * 0x00000000, unsigned int 0) line 66
nsHttpChannel::OnStopRequest(nsHttpChannel * const 0x03c602c4, nsIRequest *
0x03fca474, nsISupports * 0x00000000, unsigned int 0) line 2931
nsOnStopRequestEvent::HandleEvent() line 213
nsARequestObserverEvent::HandlePLEvent(PLEvent * 0x0518b54c) line 116
PL_HandleEvent(PLEvent * 0x0518b54c) line 596 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x01036ed8) line 526 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x000203ba, unsigned int 49412, unsigned int 0,
long 17002200) line 1077 + 9 bytes
USER32! 77e01d0a()
USER32! 77e01bc8()
USER32! 77e072b4()
nsAppShellService::Run(nsAppShellService * const 0x015fba10) line 452
main1(int 2, char * * 0x00283160, nsISupports * 0x00000000) line 1518 + 32 bytes
main(int 2, char * * 0x00283160) line 1878 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e8ca90()

We have only one problem here : Mozilla should not crash

-> Image:GFX
Assignee: Matti → pavlov
Component: Browser-General → Image: GFX
Keywords: stackwanted
QA Contact: asa → tpreston

Comment 8

16 years ago
Created attachment 93852 [details]
Talkback stacks from incidents in comment #0
Thanks greer for the stacks !

The stack are random and this should be a dupe of bug 151154

*** This bug has been marked as a duplicate of 151154 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED

Updated

16 years ago
Summary: Crash on page load → Crash on page load [favicon]

Updated

9 years ago
Component: Image: Painting → Image: Painting
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.