Closed Bug 16085 Opened 20 years ago Closed 20 years ago

[DOGFOOD]4.x can't break quoting from mozilla

Categories

(MailNews Core :: Composition, defect, P3, critical)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: phil, Assigned: mozeditor)

Details

(Whiteboard: [PDT-})

I was trying to reply to news://news.mozilla.org/380227C0.5050702@netscape.com
(which was written with mozilla) using 4.61, and when I put the cursor in the
quoted material and hit enter, 4.61 couldn't break the quoting. Maybe this has
to do with having the body in a <div>?

I'm guessing this is an output problem, so I'm starting with akkana, and cc'ing
other involved folks.
assigned to joe, to see if it's a rules problem.  if it is an output problem,
reassign to akkana (who is on vacation all this week.)
cc'ing bijal who did the compatibility test for our mail rules.
assigned to joe, to see if it's a rules problem.  if it is an output problem,
reassign to akkana (who is on vacation all this week.)
cc'ing bijal who did the compatibility test for our mail rules.
Summary: 4.x can't break quoting from mozilla → [DOGFOOD]4.x can't break quoting from mozilla
Nominate for dogfood
Whiteboard: [PDT-}
Putting on [PDT-] radar.
accepting/m11
Target Milestone: M11 → M14
Beth and I just looked at this.  Here's what's happening: when I send an html
reply using mozilla, quotes are wrapped in <blockquote type=CITE> and properly
split, new (non-quoted) text is wrapped in <div type="_moz">.  There are
occasional extra </blockquote> tags (I'll look into that, might be an output
problem) but they don't seem to affect the rest of this.

If you then read one of these mozilla-generated replies with 4.61, and reply to
it in 4.61 html mail compose, put your cursor inside the quoted div (i.e. the
part that was typed in original text in mozilla html compose and then quoted by
4.61, not the part that was originally quoted by mozilla), the div breaks but
the enclosing blockquote doesn't.  So you're left typing inside one level of
blockquote instead of at the top level.

In other words, it looks like 4.61 can't properly handle replying to our <div
type="_moz"> mail rules.
Aaaaaaaaaaaaaahhhhhhhh!
Target Milestone: M14 → M13
Kin and I looked at it yesterday too. We started messing around with the
underlying HTML and what we found was that the <DIV type=_moz> gets handled
about the same way as the text within the <DIV> element. In the 4.x mail, when a
<DIV> element is encountered, it strips out the <DIV> and collapses the the
contained text into the parent -- for example:

original sample:
<blockquote TYPE=CITE>Here is some text. <div TYPE=_moz>Here is the div text.
<p>Here is the second para.</BLOCKQUOTE>


When you reply, you would expect to break within the <BLOCKQUOTE> and also
within the <DIV> -- Here is what happens:

<p>Beth Epperson wrote:
<blockquote TYPE=CITE>here is the reply
     <p>Beth Epperson wrote:
     <blockquote TYPE=CITE>Here is</blockquote>
</blockquote>
HERE IS MY FIRST REPLY
<blockquote TYPE=CITE>
     <blockquote TYPE=CITE>some text.
          <div TYPE=_moz>Right here is
               <p>HERE IS MY SECOND
               <p>the div text.</div>
          Here is the second para.
     </blockquote>
</blockquote>

Notice the break in the blockquote results in a </BLOCKQUOTE>, however, within
the <DIV> the result is a <P>.

Kin believed it has something to do with our usage of the <DIV> element within
4.x. If our memories serve us correctly, we were using DIV to help us set
alignment.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fixed.  mail-compose editors no longer wrap text in divs by default.  Normal
messages should work fine when replied to within 4.x now.
QA Contact: lchiang → pmock
Status: RESOLVED → VERIFIED
Verified as fixed on win, mac, and linux using the following builds:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-01-03-09-M13/sea
monkey32e.exe
ftp://sweetlou/products/client/seamonkey/unix/linux_glibc/2.2/x86/2000-01-03-08-
M13/netscape-i686-pc-linux-gnu.tar.gz
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/2000-01-03-08-M13/NSMacIn
staller-M13.sea.bin

I posted test messages from 5.0 from each platform and used 4.7 rtm to verify
that I could break the quoting.  Note: I used 4.7 since I was able to reproduce
the original problem using 4.7.  I checked the page source of the 5.0 message
and mail-compose editors no longer wrap text in divs by default.

Verified as fixed.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.