Long links don't word wrap, forcing wide pages

RESOLVED DUPLICATE of bug 95067

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 95067
16 years ago
14 years ago

People

(Reporter: Kerry Shetline, Assigned: Matti)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Build 2002072203:

I just ran into a web page where someone used a very long-winded bit of text to
make a link. As a result, the format of a web page on this bulletin-board web
site, which normally scales to fit any typical window width, became very wide. A
horizontal scroll bar appears, and reading the web page requires scrolling back
and forth over a very wide area.

Here are some sample images:
http://www.shetline.com/bugpics/long_link_left_side.gif
http://www.shetline.com/bugpics/long_link_right_side.gif


Please note that this link:

http://forums.appleinsider.com/cgi-bin/ultimatebb.cgi?ubb=get_topic&f=12&t=000079

...is time sensitive. Messages on the bulletin board have a time limit, so this
link might not work, or might not go to the proper example, if the link is used
too long after this bug was reported.

Comment 1

16 years ago
Kerry, that's the correct behavior. Browsers aren't supposed to wrap text except
at white space. See
[http://www.w3.org/TR/1998/REC-html40-19980424/struct/text.html#idx-text-2].

Resolving Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

16 years ago
(See also bug 26279, bug 43181, bug 49756, etc.)
v
Status: RESOLVED → VERIFIED

Comment 4

16 years ago
I think the issue is not that the link itself doesn't wrap, but that the rest of
the text on the page no longer wraps to stay inside the window. AFAICT this only
happens inside a table. For example,

<body>
  [text]
  [long link]
  [text]
</body>
the link will go off the screen, but the other text will wrap and stay on the
screen...scrolling only necessary to see the link

<body>
  <table>
    <tr>
      <td>
        [text]
        [long link]
        [text]
      </td>
    </tr>
  </table>
</body>
the link goes off the screen, making the table wider, and also making the rest
of the text wrap to the new width of the table, not to the width of the
screen...scrolling necessary to see all lines of text, not just the link

Reporter, is this the issue?
(Reporter)

Comment 5

16 years ago
I'm not sure if being in a table matters or not. Take a look at this image of
the same sample web page, as displayed with Internet Explorer:

http://www.shetline.com/bugpics/long_link_ie.gif

IE word wraps the link itself. Since the link uses regular spaces, not
non-breaking spaces, this seems to be the most reasonable way to handle such a link.
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

16 years ago
The link that makes the page wide in Mozilla is lower on the page.  It is
http:////www.google.com/search?q=cache:r5L-LcEe-38C:jews-for-allah.org/e-books/Quranic-corrections-JewishBible.pdf+%22adam+and+eve%22+%2B+%22family+tree%22+%2B+arabic&hl=en&ie=UTF-8.
IE wraps after the - and again after a %.  Mozilla does not wrap at hyphens (bug
95067), which makes long raw-URL links scroll.  If a long line is inside a
table, this makes the entire table wider (a good reason not to use table layouts
for public forums).

The patch in bug 95067 makes Mozilla wrap at hyphens and %s.

*** This bug has been marked as a duplicate of 95067 ***

*** This bug has been marked as a duplicate of 95067 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.