Closed Bug 1608584 Opened 3 years ago Closed 3 years ago

Perma [tier2] browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | Uncaught exception - [Exception... "(null)" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "<unknown>" data: no]

Categories

(Core :: WebRTC, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: enndeakin)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [retriggered])

Attachments

(1 file)

Filed by: ccoroiu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=284467030&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/G3EU908tQ3-s_UHZEt8QgA/runs/0/artifacts/public/logs/live_backing.log


[task 2020-01-10T22:18:07.141Z] 22:18:07 INFO - TEST-PASS | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | only one global indicator window -
[task 2020-01-10T22:18:07.141Z] 22:18:07 INFO - reloading the web page
[task 2020-01-10T22:18:07.142Z] 22:18:07 INFO - Buffered messages finished
[task 2020-01-10T22:18:07.142Z] 22:18:07 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | Uncaught exception - [Exception... "(null)" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "<unknown>" data: no]
[task 2020-01-10T22:18:07.143Z] 22:18:07 INFO - Leaving test bound test_outofprocess
[task 2020-01-10T22:18:07.143Z] 22:18:07 INFO - GECKO(2897) | TEST DEVICES: Using media devices:
[task 2020-01-10T22:18:07.148Z] 22:18:07 INFO - GECKO(2897) | audio:
[task 2020-01-10T22:18:07.148Z] 22:18:07 INFO - GECKO(2897) | video:
[task 2020-01-10T22:18:07.148Z] 22:18:07 INFO - GECKO(2897) | MEMORY STAT | vsize 3011MB | residentFast 380MB | heapAllocated 153MB
[task 2020-01-10T22:18:07.149Z] 22:18:07 INFO - TEST-OK | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | took 4687ms
[task 2020-01-10T22:18:07.149Z] 22:18:07 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-01-10T22:18:07.150Z] 22:18:07 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/webrtc/browser_devices_get_user_media_in_frame.js | Found an unexpected tab at the end of test run: https://example.com/browser/browser/base/content/test/webrtc/get_user_media_in_oop_frame.html -
[task 2020-01-10T22:18:07.151Z] 22:18:07 INFO - checking window state

Has Regression Range: --- → yes
Keywords: regression

I won't be able to fix this until next week. I'd suggest for now just disabling the test in fission mode only, as it only seems to fail there (and the part that is failing is meant to test fission-specific things anyway)

Flags: needinfo?(enndeakin)

Neil, this is almost "disable recommended", did you get a chance to look into this?
Also, bug 1608497 is very frequent and seems related.

Flags: needinfo?(enndeakin)

Yes, I think I know what the problem is and am testing a fix. The other bug is a non-fission mode version of the same issue.

Flags: needinfo?(enndeakin)
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a9619fd7915e
shouldn't pass true to browserLoaded to wait for the subframe to load, also fixes 1608497, r=johannh
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
You need to log in before you can comment on or make changes to this bug.