Closed Bug 1608724 Opened 2 years ago Closed 2 years ago

mach bootstrap fails on fresh checkout on Linux (lucetc)

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1608753

People

(Reporter: gw, Unassigned)

Details

On a fresh checkout of m-c, running ./mach bootstrap I see:

 0:01.87 Could not find a toolchain build named `lucetc`
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

CalledProcessError: Command '['/usr/bin/python2.7', u'/home/code/work/gecko1/mach', u'artifact', u'toolchain', u'--from-build', u'lucetc']' returned non-zero exit status 1

  File "/home/code/work/gecko1/python/mozboot/mozboot/mach_commands.py", line 44, in bootstrap
    bootstrapper.bootstrap()
  File "/home/code/work/gecko1/python/mozboot/mozboot/bootstrap.py", line 536, in bootstrap
    checkout_root)
  File "/home/code/work/gecko1/python/mozboot/mozboot/bootstrap.py", line 401, in maybe_install_private_packages_or_exit
    self.instance.ensure_lucetc_packages(state_dir, checkout_root)
  File "/home/code/work/gecko1/python/mozboot/mozboot/linux_common.py", line 36, in ensure_lucetc_packages
    lucetc.LINUX_LUCETC)
  File "/home/code/work/gecko1/python/mozboot/mozboot/base.py", line 340, in install_toolchain_artifact
    subprocess.check_call(cmd, cwd=state_dir)
  File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
    raise CalledProcessError(retcode, cmd)

This is on a machine running Kubuntu 19.10. The source code was checked out with git cinnabar. The same error occurs consistently if I re-run ./mach bootstrap.

I commented out the call to ensure_lucetc_packages and that allows bootstrap and build to complete successfully.

Duplicating forward, because of dependencies and needinfos on the other bug.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1608753
You need to log in before you can comment on or make changes to this bug.