SMTP AUTH bug with server returns 4xx error code

RESOLVED FIXED

Status

MailNews Core
Networking: SMTP
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: Sébastien Bouchex Bellomié, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When SMTP client is trying to login by using SMTP AUTH (LOGIN scheme) and the
server answers a 4xx error code (saying "server temporary down"), the mail
client is trying to log in again immediatly without notifying the problem to the
user.

The best would be to retry later...

The bug is in the nsSmtpProtocol::AuthLoginResponse function because you don't
take care of the 4xx error code (only 2xx, 3xx and 5xx)
(Reporter)

Comment 1

15 years ago
The problem seems to be fixed with later version of Mozilla and Thunderbird.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.