Closed Bug 1608753 Opened 6 months ago Closed 6 months ago

bootstrap fails after unpacking sccache (Could not find a toolchain build named lucetc)

Categories

(Firefox Build System :: Bootstrap Configuration, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(firefox-esr68 unaffected, firefox72 unaffected, firefox73 unaffected, firefox74 fixed)

RESOLVED FIXED
mozilla74
Tracking Status
firefox-esr68 --- unaffected
firefox72 --- unaffected
firefox73 --- unaffected
firefox74 --- fixed

People

(Reporter: pbone, Assigned: froydnj)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

I get the following error from ./mach bootstrap, I use Mint Linux (Like Ubuntu) on x86_64. I believe Bug 1608428 creates this regression, bootstrap works without it, but fails with it. Thanks.

0:02.56 Using artifact from local cache: /home/paul/.mozbuild/toolchains/74cc61d37c99b38b-sccache.tar.xz
0:02.60 rm tree: /home/paul/.mozbuild/sccache
0:02.60 untarring "/home/paul/.mozbuild/sccache.tar.xz"
0:01.93 Could not find a toolchain build named lucetc
Error running mach:

['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

CalledProcessError: Command '['/usr/bin/python2.7', u'/mnt/dev/moz/fission/mach', u'artifact', u'toolchain', u'--from-build', u'lucetc']' returned non-zero exit status 1

File "/mnt/dev/moz/fission/python/mozboot/mozboot/mach_commands.py", line 44, in bootstrap
bootstrapper.bootstrap()
File "/mnt/dev/moz/fission/python/mozboot/mozboot/bootstrap.py", line 536, in bootstrap
checkout_root)
File "/mnt/dev/moz/fission/python/mozboot/mozboot/bootstrap.py", line 401, in maybe_install_private_packages_or_exit
self.instance.ensure_lucetc_packages(state_dir, checkout_root)
File "/mnt/dev/moz/fission/python/mozboot/mozboot/linux_common.py", line 36, in ensure_lucetc_packages
lucetc.LINUX_LUCETC)
File "/mnt/dev/moz/fission/python/mozboot/mozboot/base.py", line 340, in install_toolchain_artifact
subprocess.check_call(cmd, cwd=state_dir)
File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
raise CalledProcessError(retcode, cmd)

Flags: needinfo?(nfroyd)
Summary: bootstrap fails after unpaccing sccache → bootstrap fails after unpacking sccache
Summary: bootstrap fails after unpacking sccache → bootstrap fails after unpacking sccache (Could not find a toolchain build named lucetc)

Bug 1608724 suggests a workaround: in python/mozboot/mozboot/bootstrap.py, uncomment the call to ensure_lucetc_packages. Works for me, though I've built only the JS shell afterwards, not the whole of Firefox.

Sorry, I'm dumb; I have a patch.

Assignee: nobody → nfroyd
Status: NEW → ASSIGNED
Flags: needinfo?(nfroyd)

We renamed the toolchain task in bug 1608428 and we forgot to update
bootstrap along with the renaming.

Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90754ce54f5b
download the correct lucet package in bootstrap; r=emilio
Pushed by dluca@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/1ba5465db9d1
download the correct lucet package in bootstrap; r=emilio a=Aryx
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74

Thanks Nathan, that's fixed it.

You need to log in before you can comment on or make changes to this bug.