Closed Bug 1608814 Opened 1 year ago Closed 1 year ago

Add native system tray functionality for Thunderbird

Categories

(Thunderbird :: OS Integration, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 208923

People

(Reporter: pclmcmullan, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Steps to reproduce:

Without resorting to now-abandoned add-ons or third-party applications, it's impossible to send Thunderbird to the tray area. A program such as Thunderbird, that will usually be open on the user's desktop for some time, pinging for new mail every X minutes, should really have this functionality in-built.

Actual results:

The only add-on that worked for this is now abandoned and unusable, thanks to Thunderbird disabling older add-ons, as well as the code of the add-on in question being outdated to the point that an entire rewrite is required (one that the add-on author has said he has no intention of doing any time soon).

This should be an optional in-built feature. It's frankly bizarre that it's been requested for the last 17 years (!) but still hasn't been deemed worth adding.

https://bugzilla.mozilla.org/show_bug.cgi?id=208923

Expected results:

Minimizing/closing to the system tray is what should happen, assuming the user has enabled that option in the program's preferences.

Indeed there are no plans to provide this natively. https://bugzilla.mozilla.org/show_bug.cgi?id=208923#user-story describes your options

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 208923
You need to log in before you can comment on or make changes to this bug.