Closed Bug 1608829 Opened 2 years ago Closed 2 years ago

"Learn more" link in the Data Collection section on about:preferences is in a second line instead of the same line

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 74
Tracking Status
firefox-esr68 --- unaffected
firefox72 --- unaffected
firefox73 --- unaffected
firefox74 --- verified

People

(Reporter: itiel_yn8, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1608802 +++

STR:

  1. Open about:preferences#privacy
  2. Scroll to the Data Collection section, see the "Allow Nightly to send technical and interaction data to Mozilla" checkbox

AR:
"Learn More" link in a new line

ER:
Should be in the same line.

Regressed by bug 1606130.

Giving the checkbox display: -moz-inline-box fixes this, along the lines of https://phabricator.services.mozilla.com/D59093 .

Emilio, can you help me understand why this checkbox and (as far as I can tell) only this checkbox is affected here, and/or how we'd look for other elements that may have started behaving differently under the circumstances?

Flags: needinfo?(emilio)

Because that checkbox is the only one directly below an HTML block (<description> always has an HTML block layout). The others are inside an hbox or such.

Flags: needinfo?(emilio)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED

(In reply to Emilio Cobos Álvarez (:emilio) from comment #2)

Because that checkbox is the only one directly below an HTML block (<description> always has an HTML block layout). The others are inside an hbox or such.

OK. I did a quick check, I don't think there are other <checkbox> elements directly inside a <description> in either the prefs or other parts of the codebase, so let's just fix this one checkbox...

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/850151a68fbe
fix wrapping of telemetry checkbox in the preferences/options, r=emilio
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74
Status: RESOLVED → VERIFIED

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)

Please nominate this for Beta approval when you get a chance.

This bit me in bug 1608802 as well, but I don't think beta is affected? See https://bugzilla.mozilla.org/show_bug.cgi?id=1608802#c7 . We landed https://hg.mozilla.org/integration/autoland/rev/0aa32e6d6d58 in 73, which won't have caused this regression; whereas https://hg.mozilla.org/mozilla-central/rev/be0ddae5d705 did, but only landed in 74. In hindsight, we should have split the bug - sorry, lesson learned...

Flags: needinfo?(gijskruitbosch+bugs)
You need to log in before you can comment on or make changes to this bug.