Closed Bug 160896 Opened 18 years ago Closed 7 years ago

Make integration preferences extensible (non-hard-coded)

Categories

(Core :: Preferences: Backend, defect)

x86
Windows 95
defect
Not set

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: megabyte, Unassigned)

Details

There has got to be a better way than adding practically duplicate entries to a
multitude of files to add file/protocol integration options.  These should be
read from a file and add-on apps should have the ability to integrate in the
future. Ex: Say a telnet client was developed and needed telnet: registered. 
This is impossible when the code is part of the compiled build.
qa contact windows integration-> pmac
QA Contact: paw → pmac
Summary: Make integration preferences non-hard-coded → Make integration preferences extensible (non-hard-coded)
Is this a dupe of Bug 68406?
No, not at all.  That bug is talking about registering URIs so Mozilla will
launch particular programs.  This bug is so that Windows will launch Mozilla
components with particular URIs or file extensions.
Product: Core → Mozilla Application Suite
Assignee: samir_bugzilla → jag
QA Contact: pmac
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → EXPIRED
Assignee: jag-mozilla → nobody
Status: RESOLVED → REOPENED
Component: UI Design → Preferences: Backend
Ever confirmed: true
Product: SeaMonkey → Core
QA Contact: preferences-backend
Resolution: EXPIRED → ---
Status: REOPENED → RESOLVED
Closed: 10 years ago7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.