Mozilla won't start up properly when application folder contains Unicode character

VERIFIED WORKSFORME

Status

()

Core
Internationalization
--
major
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Greg K., Assigned: Frank Tang)

Tracking

({intl})

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020801
BuildID:    2002080303

If a Unicode character is added to the name of the folder containing the Mozilla
application, then the Mozilla application will not start up completely.

Reproducible: Always
Steps to Reproduce:
1. Append the text " 1.1" to the name of the Mozilla folder
2. Select the Unicode Hex Input keyboard layout
3. Press option+03b2 to insert the Greek lowercase beta character
4. Press return
5. Launch Mozilla

Actual Results:  Mozilla fails to start up completely. Only the Mozilla menubar
item is shown, and a small window fragment is visible just underneath the
menubar. Mozilla can be quit successfully at this point, though.

Expected Results:  Mozilla should have started up completely.

Though the method is different, the results resemble those of bug 138827.
Whiteboard: DUPEME
-> Int
Assignee: Matti → yokoyama
Component: Browser-General → Internationalization
QA Contact: asa → ruixu
(Reporter)

Comment 2

16 years ago
Adding qawanted to match Matti's DUPEME.
Keywords: qawanted

Comment 3

16 years ago
ruix: do we have a duplicate bug?  This sounds familiar to MacOS.

Comment 4

16 years ago
It happens when the application path contain unicode characters, it might be 
related to bug 107181.
Keywords: intl
(Assignee)

Comment 5

15 years ago
bad bug. estimate of efforts 7 days
Assignee: yokoyama → ftang
(Assignee)

Updated

15 years ago
Keywords: nsbeta1
(Assignee)

Comment 6

15 years ago
assign 
Status: NEW → ASSIGNED
(Reporter)

Comment 7

15 years ago
Apparently WorksForMe using FizzillaMach/2003020603. I appended U03B2 to the
Mozilla package name, and it launched successfully.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Whiteboard: DUPEME

Updated

15 years ago
QA Contact: ruixu → ylong

Comment 8

15 years ago
It's actually crashed when I rename netscape Mach-O 02-19 package name contains
03B2 on Mac 10.2.4.  Not sure if it is blocked by bug 191234.

I'm re-open this bug for now, will follow a crash report. 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 9

15 years ago
Created attachment 114905 [details]
crash log file with 02-19 Mach-O build on 10.2.4
(Reporter)

Comment 10

15 years ago
Yuying, you should probably file that as a separate bug. Also, I see possible
AIM-related stuff on that stack ("nsAimSession"); does this belong on Bugscape
rather than Bugzilla? Mozilla doesn't include an AIM client. If your crash
happened on a Netscape build, it belongs on Bugscape instead.

Comment 11

15 years ago
You are right.  Mozilla build doesn't has this problem.  Reslove again as
worksforme.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME

Comment 12

15 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.