[BLOCKER] [PP]Crashing on both mozilla and commercial builds 10/11

VERIFIED FIXED in M11

Status

SeaMonkey
Build Config
P3
blocker
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Grace Bush, Assigned: Simon Fraser)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Steps to reproduce:
1. Remove mozregistry and documents folder
2. Click on apprunner icon or Mozilla Installer icon

Actual results: Crash
Expected results: CreateProfile Wizard

log to follow
builds on mac only
---------------------------------------
stack trace
Calling chain using A6/R1 links
  Back chain  ISA  Caller
 Return addresses on the stack
  Stack Addr  Frame Addr   ISA   Caller
   039F8516                68K   001BDEE0 'scod BFAF 0002'+12170
   039F8512                68K   0063AE1C
   039F850A                68K   0063AE1C
   039F84EE    039F84EA    68K   0063AD78
   039F84E2    039F84DE    68K   004BBE4C InitAppGuts+0001C
   039F84CE                68K   001BDDF4 'scod BFAF 0002'+12084
   039F84C8                PPC   001D523C EmToNatEndMoveParams+00014
   039F84B6                68K   001BDDF4 'scod BFAF 0002'+12084
   039F849A                68K   001AC1A8 'scod BFAF 0002'+00438
   039F8488                PPC   001D523C EmToNatEndMoveParams+00014
   039F8478                68K   002716FE
   039F846C                68K   039F8514
   039F8460                68K   0063AE10
   039F8448    039F8440    PPC   0C034550 NQDSetPort+00034
   039F841C                68K   001BDEE0 'scod BFAF 0002'+12170
   039F8412    039F840E    68K   001B177A 'scod BFAF 0002'+05A0A
   039F8404    039F8400    68K   001B1770 'scod BFAF 0002'+05A00
   039F83EA    039F83E6    68K   001B174C 'scod BFAF 0002'+059DC
   039F83E2    039F83DE    68K   001CC7D8
   039F83C8                PPC   001D523C EmToNatEndMoveParams+00014
   039F83C4                68K   001CD69C
   039F83AA                68K   001CC334
   039F83A0    039F839C    68K   0006D59C
   039F8398                68K   0063AE1C
   039F8388                PPC   0BA84360
   039F8364                68K   001B174C 'scod BFAF 0002'+059DC
   039F8338    039F8330    PPC   001D4180 NewRoutineDescriptor+00030
   039F8318    039F8310    PPC   0BA81720 main+00114
   039F82F4                68K   001B177A 'scod BFAF 0002'+05A0A
   039F82A8    039F82A0    PPC   0B937648 NS_InitXPCOM(nsIServiceManager**,
nsFileSpec*,
nsFi
leSpec*)+007CC
   039F81BE                PPC   006F0068
   039F8174                68K   02E41BB6
   039F8158    039F8150    PPC   0BA80E60 main1(int, char**)+00294
   039F8138                68K   02EDCD92
   039F8118    039F8110    PPC   0BA82144 NS_SetupRegistry_1+00214
   039F8108    039F8100    PPC   0B8F2948 nsServiceManager::GetService(const
nsID&,
const nsI
D&, nsISupports**, nsIShutdownListener*)+00050
   039F80F8    039F80F0    PPC   0AC9B2C0
nsAppShellService::Initialize(nsICmdLineService*)+0
0200

Updated

19 years ago
Summary: [PP]Crashing on both mozilla and commercial builds 10/11 → [BLOCKER] [PP]Crashing on both mozilla and commercial builds 10/11

Comment 1

19 years ago
adding myself to cc: list.

Comment 2

19 years ago
we are seeing this on our verification build system as well.  tinderbox page
updated.  contacting mac developers.

Comment 3

19 years ago
Created attachment 2079 [details]
stack trace of mozilla crash on startup on mac
is this a duplicate of the bug sfraser is working on?

#15795

Updated

19 years ago
Assignee: granrose → sfraser

Comment 5

19 years ago
possibly.  talked to sfraser, he has a fix being reviewed by dougt.  reassigning
to sfraser.

Updated

19 years ago
Target Milestone: M11
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
Fix checked in

Comment 7

19 years ago
*** Bug 16088 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

19 years ago
mozilla build 1999101114 is not crashing
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

19 years ago
builds 19991012 are ok too
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.