Closed Bug 1609219 Opened 3 years ago Closed 11 months ago

Timezone should default to the local system timezone

Categories

(Calendar :: Internal Components, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1158733

People

(Reporter: tim, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Steps to reproduce:

Thunderbird version 68.4.1, 32 bit
Windows 10 Pro, version 1903

I occasionally receive meeting invitations via email. Until today, I was not aware that Thunderbird has a timezone setting and that it wasn't matched to my local timezone. Unfortunately, this created a meeting scheduling problem due to the timezone mismatch until I discovered this setting (Tools > Options > Calendar > Timezone) and corrected it.

Actual results:

The Thunderbird timezone was set to "America/Chicago" (Central) instead of "America/Denver" (Mountain), which is the local system timezone.

Expected results:

Can the Thunderbird timezone setting default to the local system timezone unless changed by the user? This could reduce event scheduling issues for users (like myself) who don't regularly use the Events / Calendar functions? This could also streamline application configuration for most users.

I thought it was already done that way. I do not ever remember changing the timezone in Lightning, but it is a very long time since I first installed it.

I just tested Thunderbird 68.4.1 with a new test profile.

My calendar timezone is set to the closest city in my timezone America/New York by default.

Component: Untriaged → Internal Components
Product: Thunderbird → Calendar
Version: 68 → unspecified
Depends on: 1158733
Summary: Feature Request: Can the Thunderbird timezone default to the local system timezone? → Timezone default to the local system timezone
Status: UNCONFIRMED → NEW
Ever confirmed: true

I tend to resolve this bug report as duplicate of bug 1158733. Any objections?

Sounds good!

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Summary: Timezone default to the local system timezone → Timezone should default to the local system timezone
Duplicate of bug: 1158733
No longer depends on: 1158733
You need to log in before you can comment on or make changes to this bug.