Newsreader says there is unread articles even if not (due to cancelled posting)

RESOLVED DUPLICATE of bug 79130

Status

RESOLVED DUPLICATE of bug 79130
17 years ago
10 years ago

People

(Reporter: tetsuji.rai, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020803
BuildID:    2002080321

When some articles are cancelled in a newsgroup(for ex, in newsrc-(newsserver),
1-1000,1003-1005) Mozilla newsreader says there are some unread articles.  I
found this bug a long time ago.  When going to that group, the newsgroup turns
to "all read."   Very confusing.

Reproducible: Always
Steps to Reproduce:
Just make a cancelled article in a newsgroup (for ex: in local.test or something
like that) followed by a real article.  And mark that newsgroup "all read." 
Once close newsreader, and open the newsreader again.  Thsn mozilla will say
there is(are) unread article(s) in that newsgroup.

Comment 1

16 years ago
*** Bug 166980 has been marked as a duplicate of this bug. ***

Updated

15 years ago
OS: Linux → All
Hardware: PC → All

Comment 2

15 years ago
*** Bug 239153 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
just carrying over info:

I've tracked it down to the "news.mozilla.org.rc" file
In a working copy I have:
netscape.public.mozilla.dom: 1-7845
and in the NON working copy I have:
netscape.public.mozilla.dom: 1-7790,7792-7845

so Mozilla says that I have one new posting.
since mozilla thinks I've read: 1-7790,7792-7845
and the server has 7845 postings
Summary: Newsreader says there is unread articles even if not → Newsreader says there is unread articles even if not (due to cancelled posting)
Product: MailNews → Core

Comment 4

13 years ago
(In reply to comment #3)
> just carrying over info:
> 
> I've tracked it down to the "news.mozilla.org.rc" file
> In a working copy I have:
> netscape.public.mozilla.dom: 1-7845
> and in the NON working copy I have:
> netscape.public.mozilla.dom: 1-7790,7792-7845

changing 1-7790,7792-7845 to 1-7854 will workaround this problem.

Comment 5

13 years ago
> changing 1-7790,7792-7845 to 1-7854 will workaround this problem.

that comment is a joke, I hope?

Comment 6

13 years ago
No, I also found that this workaround works. What do you find funny about that?

Btw, is this a dupe of bug 41457? Bug 90991 and/or bug 101503 could also be related.

Comment 7

13 years ago
Ah, now I found the correct dupe...

*** This bug has been marked as a duplicate of 79130 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 8

13 years ago
(In reply to comment #6)
> No, I also found that this workaround works. What do you find funny about that?

this is a major hassle not a workaround. a workaround would be if i could use it somehow. but exit tb, edit a file (find it first...) make the correct change save and restart tb. that is not a workaround to me...
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.