Closed Bug 1609746 Opened 1 year ago Closed 1 year ago

[Fission] <select> appears in top left

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Fission Milestone M6

People

(Reporter: perry, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: reproducible)

Attachments

(2 files)

Attached image actual

STR:

Set fission.autostart=true

  1. Go to https://www.alphaindustries.com/pages/store-locator
  2. Select "Choose Country"

Expected results: select menu appears right below where mouse clicked (I get the expected results when fission.autostart=false).

Actual results: select menu appears in the top left of the page

WFM on linux, is there any chance you can run mozregression to find a regression range?

Priority: -- → P2

(In reply to Emilio Cobos Álvarez (:emilio) from comment #2)

WFM on linux, is there any chance you can run mozregression to find a regression range?

Looks like it's something to do with my specific setup. I tried the same Nightly using a clean profile and it works normally. Looking...

Okay, so with a clean profile and fission.autostart=true, this reproduces.

Fission Milestone: --- → ?
Summary: <select> appears in top left → [Fission] <select> appears in top left

It looks like the dropdown is being positioned with its offset relative to the iframe, but applied relative to the tab. That probably makes sense, if we're not explicitly including the tab-to-iframe offset.

I don't think this is a regression. I can reproduce this bug (using mozregression) at least as far back as June 2019.

Tracking for Fission Nightly (M6)

Fission Milestone: ? → M6
Attachment #9121361 - Attachment description: expected-release → expected
Attachment #9121360 - Attachment description: actual-nightly → actual

Setting to P3 since this is only present with Fission enabled (and we don't yet ship Fission). Blocking rendering's Fission meta bug.

Priority: P2 → P3

This will be fixed by bug 1550800 as far as I can tell.

Depends on: 1550800

Fixed by bug 1550800.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.