Bad filename when saving images with spaces in name

VERIFIED DUPLICATE of bug 76799

Status

VERIFIED DUPLICATE of bug 76799
16 years ago
10 years ago

People

(Reporter: mail, Assigned: mscott)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

Saving attached images thru 'Save image as...' is ok when doing
it from the list of attached files.
Doing it by a right click on the image, a file named
'Pic With Spaces.gif' gives 'Pic%20With%20Spaces.gif'
in the 'Save as' dialog.



Reproducible: Always
Steps to Reproduce:
1.
Send you a mail or post to usenet with attached image
'Pic With Spaces.gif'
2.
Open the mail or the posting
3.
right click on the image
4. 
choose 'Save image as...'


Actual Results:  wrong filename 'Pic%20With%20Spaces.gif'

Expected Results:  correct filname 'Pic With Spaces.gif'

Comment 1

16 years ago
CONFIRMED on

Mozilla
Mozilla 1.1b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Comment 2

16 years ago
Sorry to say, but I cannot confirm this one with trunk build 2002080404 - WinXP.

No %20 instead of spaces.

Reporter : tried with a blank profile ? Or even a younger build ?

*** This bug has been marked as a duplicate of 76799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.