Closed Bug 1609785 Opened 6 months ago Closed 6 months ago

Unable to run ./mach bootstrap on brand new Windows install - expected unicode for dictionary value @ data[u'env'][u'MOZ_SCM_LEVEL']

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1524639

People

(Reporter: mkaply, Unassigned)

References

(Blocks 1 open bug)

Details

I have a brand new Windows 10 install, everything new. Fresh checkout, running mach bootstrap I get:

Error running mach:

    ['artifact', 'toolchain', '--from-build', 'win64-node']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

Exception: In task.run u'fetch-web-tooling-benchmark':
expected unicode for dictionary value @ data[u'env'][u'MOZ_SCM_LEVEL']
{u'allow-ptrace': False,
 u'artifacts': [{u'name': u'public',
                 u'path': u'/builds/worker/artifacts',
                 u'type': u'directory'}],
 u'chain-of-trust': True,
 u'command': [u'/builds/worker/bin/run-task',
              u'--fetch-hgfingerprint',
              u'--',
              u'/builds/worker/bin/fetch-content',
              u'static-url',
              u'--sha256',
              u'93b0b51df0cec3ca9bfa0bdf81d782306dcf18532e39b3ff3180409125daaff1',
              u'--size',
              u'5444135',
              u'https://github.com/mozilla/perf-automation/releases/download/V1/web-tooling-benchmark-b2ac25c897c9.zip',
              u'/builds/worker/artifacts/web-tooling-benchmark-b2ac25c897c9.zip'],
 u'docker-image': {u'in-tree': u'fetch'},
 u'docker-in-docker': False,
 u'env': {u'MOZ_SCM_LEVEL': '3'},
 u'implementation': u'docker-worker',
 u'loopback-audio': False,
 u'loopback-video': False,
 u'max-run-time': 900,
 u'os': u'linux',
 u'privileged': False,
 u'taskcluster-proxy': False,
 u'volumes': []}

  File "d:\mozilla-unified\python/mozbuild/mozbuild/artifact_commands.py", line 291, in artifact_toolchain
    toolchains = load_tasks_for_kind(params, 'toolchain', root_dir=root_dir)
  File "d:\mozilla-unified\taskcluster\taskgraph\generator.py", line 407, in load_tasks_for_kind
    for task in tgg.full_task_set
  File "d:\mozilla-unified\taskcluster\taskgraph\generator.py", line 142, in full_task_set
    return self._run_until('full_task_set')
  File "d:\mozilla-unified\taskcluster\taskgraph\generator.py", line 355, in _run_until
    k, v = self._run.next()
  File "d:\mozilla-unified\taskcluster\taskgraph\generator.py", line 264, in _run
    new_tasks = kind.load_tasks(parameters, list(all_tasks.values()))
  File "d:\mozilla-unified\taskcluster\taskgraph\generator.py", line 78, in load_tasks
    for task_dict in transforms(trans_config, inputs)]
  File "d:\mozilla-unified\taskcluster\taskgraph\transforms\task.py", line 2092, in check_run_task_caches
    for task in tasks:
  File "d:\mozilla-unified\taskcluster\taskgraph\transforms\task.py", line 2033, in check_task_dependencies
    for task in tasks:
  File "d:\mozilla-unified\taskcluster\taskgraph\transforms\task.py", line 2021, in check_task_identifiers
    for task in tasks:
  File "d:\mozilla-unified\taskcluster\taskgraph\transforms\task.py", line 2004, in chain_of_trust
    for task in tasks:
  File "d:\mozilla-unified\taskcluster\taskgraph\transforms\task.py", line 1835, in build_task
    for task in tasks:
  File "d:\mozilla-unified\taskcluster\taskgraph\transforms\task.py", line 1827, in try_task_config_chemspill_prio
    for task in tasks:
  File "d:\mozilla-unified\taskcluster\taskgraph\transforms\task.py", line 1817, in try_task_config_env
    for task in tasks:
  File "d:\mozilla-unified\taskcluster\taskgraph\transforms\task.py", line 1782, in add_index_routes
    for task in tasks:
  File "d:\mozilla-unified\taskcluster\taskgraph\transforms\task.py", line 1523, in validate
    "In task.run {!r}:".format(task.get('label', '?no-label?')))
  File "d:\mozilla-unified\taskcluster\taskgraph\util\schema.py", line 34, in validate_schema
    raise Exception('\n'.join(msg) + '\n' + pprint.pformat(obj))
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

CalledProcessError: Command '['c:\\mozilla-build\\python\\python2.7.exe', u'd:\\mozilla-unified\\mach', u'artifact', u'toolchain', u'--from-build', u'win64-node']' returned non-zero exit status 1

  File "d:\mozilla-unified\python/mozboot/mozboot/mach_commands.py", line 44, in bootstrap
    bootstrapper.bootstrap()
  File "d:\mozilla-unified\python/mozboot\mozboot\bootstrap.py", line 537, in bootstrap
    checkout_root)
  File "d:\mozilla-unified\python/mozboot\mozboot\bootstrap.py", line 395, in maybe_install_private_packages_or_exit
    self.instance.ensure_node_packages(state_dir, checkout_root)
  File "d:\mozilla-unified\python/mozboot\mozboot\mozillabuild.py", line 137, in ensure_node_packages
    state_dir, checkout_root, node_artifact)
  File "d:\mozilla-unified\python/mozboot\mozboot\base.py", line 346, in install_toolchain_artifact
    subprocess.check_call(cmd, cwd=state_dir)
  File "c:\mozilla-build\python\lib\subprocess.py", line 190, in check_call
    raise CalledProcessError(retcode, cmd)

I've tried removing my bashprofile to make sure nothing was messed up there.

I've verified there is no Unicode in my environment.

I made sure the Microsoft shortcuts for Python weren't enabled.

I'm using the latest Mozillabuild.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1524639
You need to log in before you can comment on or make changes to this bug.