Closed Bug 1609807 Opened 11 months ago Closed 10 months ago

Cookies: Samesite=none should indicate none in UI

Categories

(DevTools :: Storage Inspector, defect)

73 Branch
defect
Not set
normal

Tracking

(firefox74 fixed)

RESOLVED FIXED
Firefox 74
Tracking Status
firefox74 --- fixed

People

(Reporter: public, Assigned: public)

References

Details

Attachments

(1 file, 2 obsolete files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

Set cookies via the Console:
document.cookie = "test=test;samesite=none;secure
`document.cookie = "test2=test;secure"

Actual results:

Visiting Storage->Cookies in the dev panel, the cookies were both listed as SameSite Unset.

Expected results:

Since "Unset" isn't a true value, I would have expected "None" to display at least for the cookie specifically set or not for all which are treated as None.

When setting the about://config feature flag for Lax by default, Lax was set for cookies without a samesite indicator, so "Unset" is even more confusing in that case.

Has STR: --- → yes
Component: Untriaged → Storage Inspector
Product: Firefox → DevTools
Assignee: nobody → public
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Depends on D60242

Depends on D60524

Attachment #9122069 - Attachment is obsolete: true
Attachment #9122070 - Attachment is obsolete: true
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b4e23f6d397c
DevTools: Use label 'None' for SameSite=None cookie values. r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74
Duplicate of this bug: 1611475
Duplicate of this bug: 1613622
Duplicate of this bug: 1623783
You need to log in before you can comment on or make changes to this bug.