Closed Bug 1609857 Opened 7 months ago Closed 7 months ago

The Chat feature is not loaded on etc.clona.ru, when ETP Standard is ON

Categories

(Core :: Privacy: Anti-Tracking, defect, P1)

74 Branch
Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox74 --- verified

People

(Reporter: sergiu, Assigned: englehardt)

References

(Blocks 1 open bug, )

Details

Browser / Version
Firefox Nightly 74.0a1 (2020-01-15)

Operating System
Windows 10

Steps to reproduce:

  1. Go to https://etc.clona.ru/
  2. Observe the Chat window.

Expected Behavior:
The Chat window is loaded.

Actual Behavior:
The Chat window is not loaded.

Notes:

  1. Screenshot attached.
  2. Disabling the ETP, fixes the issue.

From the Webcompat bug 47716:

Hello, I'm the admin resource for clona.ru. The new version of your browser blocks some of the content on the *.clona.ru pages. Built-in chat (https://www.cbox.ws/), is blocked on all pages *.clona.ru

eth.clona.ru
etc.clona.ru
clo.clona.ru
exp.clona.ru
ubiq.clona.ru
pirl.clona.ru
ella.clona.ru
aka.clona.ru
nilu.clona.ru
reosc.clona.ru
moac.clona.ru
dbix.clona.ru

If you manually disable Fingerprints, then everything works.

Please add to *.cbox.ws exception for *.clona.ru sites, in new browser versions.
Chat is an integral part of the site.

Blocks: etp-breakage
No longer blocks: tp-breakage

Since this is caused by cbox.ws the breakage should be fixed if/when Disconnect verifies the changes described here. As soon as they do that we can push the fix to Firefox. I'll take this and update when there's movement on the Disconnect bug.

Assignee: nobody → senglehardt
Priority: P3 → P1
Status: NEW → ASSIGNED

These changes were deployed to all branches: https://github.com/mozilla-services/shavar-prod-lists/pull/102. Since cbox.ws is in the Content category, this is actually not broken in normal TP either. Marking as fixed.

No longer blocks: tp-breakage
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Flags: qe-verify+

I have verified that the chat window is correctly displayed on https://etc.clona.ru/ using Beta 74.0b6 (20200221001238), under Windows 10 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.