Closed Bug 1609942 Opened 1 year ago Closed 11 months ago

When eager evaluation is enabled display the autocomplete popup at the top of the input

Categories

(DevTools :: Console, task, P3)

task

Tracking

(firefox75 verified)

VERIFIED FIXED
Firefox 75
Tracking Status
firefox75 --- verified

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 5 open bugs, Regressed 3 open bugs)

Details

Attachments

(1 file)

At the moment the popup displays at the bottom of the input most of the time, which covers the eager evaluation result and make it unreadable for users.

This prevents the popup to hide the eager evaluation result.
in order for the popup to be able to appear outside of the
toolbox, we pass the useXulWrapper option to the HTMLTooltip.

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Attachment #9125813 - Attachment description: Bug 1609942 - Display autocomplete popup at the top of the input. r=jdescottes. → Bug 1609942 - Display autocomplete popup at the top of the input. r=jdescottes!, Honza!.
Attachment #9125813 - Attachment description: Bug 1609942 - Display autocomplete popup at the top of the input. r=jdescottes!, Honza!. → Bug 1609942 - Display autocomplete popup at the top of the input. r=jdescottes!,Honza!.
See Also: → 1617529
Blocks: 1617541
Blocks: 1617543
Blocks: 1618209
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ee1ac6bab06
Display autocomplete popup at the top of the input. r=jdescottes,Honza.

Didn't got to the bottom of it, but at least It looks like I got read of the failures by testing on another object than the window https://treeherder.mozilla.org/#/jobs?repo=try&revision=1ca15e99d5e241de82f9a01fa69d2ee77944492d

I took that as an opportunity to make the test more explicit about what autocomplete items are expected.

Flags: needinfo?(nchevobbe)
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c1d7d5e9a18b
Display autocomplete popup at the top of the input. r=jdescottes,Honza.
Flags: needinfo?(nchevobbe)
Flags: needinfo?(nchevobbe)
Blocks: 1620521
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a2ebc0c68234
Display autocomplete popup at the top of the input. r=jdescottes,Honza,perftest-reviewers,whimboo.
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75
Regressions: 1620622

Confirmed issue with 75.0a1 (2020-03-06) on Windows 10.
Verified fix with 75.0a1 (2020-03-08) on Windows 10, macOS 10.15, Ubuntu 19.04.

Implementation works well and is stable, however there are still a few things that might be worth pointing out:

  • when the inspector is dragged all the way up and the menu cannot be contained it is displayed as prior to this patch(over the evaluation preview);
  • when the DevTools is docked to right/left and the input is on the first rows the menu is displayed over the preview as well, until there is enough space for the menu to be displayed above.

While this is not a buggy behavior, it might be something that can be improved in the future. A few ideas that come to mind:

  • having the menu size adjusted based on the number of entries that would take to fit in the available space;
  • having the menu be displayed bellow the preview (but that might be confusing at first).
Status: RESOLVED → VERIFIED
OS: Unspecified → All
Hardware: Unspecified → All
Regressions: 1621227
Regressions: 1620724
Regressions: 1620638
Regressions: 1655406
You need to log in before you can comment on or make changes to this bug.