Closed Bug 1610260 Opened 9 months ago Closed 9 months ago

Add timeout multiplyer for ccov opt builds

Categories

(Testing :: web-platform-tests, enhancement)

Version 3
enhancement
Not set
normal

Tracking

(firefox74 fixed)

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: whimboo, Assigned: jgraham)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

At the moment the timeout multiplyer for ccov builds is only increased to 4 for ccov debug builds [1]. But since recently we only run with opt builds in CI [2].

We should make sure that a multiplier is also used for ccov opt builds because those builds are still very slow and take nearly 60s to startup on my MBP.

James, could you have a look at?

[1] https://searchfox.org/mozilla-central/rev/803a42f24c8714631ed81cb824ea1c1a803cb7b8/testing/web-platform/tests/tools/wptrunner/wptrunner/browsers/firefox.py#58
[2] https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&tier=1%2C2%2C3&searchStr=ccov%2Cwpt

Flags: needinfo?(james)
Blocks: 1608082
Blocks: 1495002
Assignee: nobody → james
Status: NEW → ASSIGNED
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/2ce3079053c7
Increase timeout multiplier for wpt ccov opt, r=whimboo
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/21490 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
Upstream PR merged by moz-wptsync-bot
Regressions: 1583591
Flags: needinfo?(james)
You need to log in before you can comment on or make changes to this bug.