Closed Bug 16108 Opened 21 years ago Closed 19 years ago

merge ns[C]String and nsXPIDL[C]String

Categories

(Core :: String, defect, P3, major)

defect

Tracking

()

RESOLVED DUPLICATE of bug 53065
mozilla0.9

People

(Reporter: waterson, Assigned: scc)

References

Details

Make the buffer management facilities of nsXPIDL[C]String (getter_Copies() and
getter_AddRefs()) part of the ns[C]String implementation.
Status: NEW → ASSIGNED
Whiteboard: HELPWANTED
Target Milestone: M18
Won't someone _please_ help a string in need? :-)
*** Bug 20723 has been marked as a duplicate of this bug. ***
Keywords: helpwanted
scc has stepped up to the plate for this. thanks, scott!
Assignee: waterson → scc
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
*** Bug 28846 has been marked as a duplicate of this bug. ***
taking this, and setting up dependancy
Assignee: scc → alecf
Status: ASSIGNED → NEW
Depends on: 28841
Thanks for the help, Alec :-)  People reading this bug report should be aware of 
the related bugs with important comments

  Bug 28846 -- (now marked duplicate) talks about adding
               |getter_CopiesWithCharset|
  Bug 28841 -- (a dependency for this bug) is influenced by this bug in which
               course of action to take
Status: NEW → ASSIGNED
Alec, would you mind if I take this back?  I'm defining a member of the new 
string hierarchy that exactly satisfies this need.
thanks scott, one less thing for me to do :)
Assignee: alecf → scc
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
mass re-assigning to my new bugzilla account
Assignee: scc → scc
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Moving this up to help us start better using strings.
Target Milestone: M18 → M17
Component: XP Miscellany → String
Keywords: helpwanted
Whiteboard: HELPWANTED
Target Milestone: M17 → mozilla0.9
Depends on: 53065
|nsXPIDL[C]String| is really like an |auto_ptr| for strings.  We're going to
merge that functionality into the shared buffer implementation described in bug
#53065.  Eventually, that implementation will replace |ns[C]String| for all
clients in mozilla.
bug #53065 already requires that the new default string, |nsCommon[C]String|,
implment |nsXPIDL[C]String| functionality.  That was how this functionality was
to be merged.  Therefore, this bug is now a dup.

*** This bug has been marked as a duplicate of 53065 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Blocks: 28221
No longer depends on: 28841, 53065
We will deprecate (and eventually remove) nsXPIDLString, right? Should we leave 
this bug open to mean that task?
You need to log in before you can comment on or make changes to this bug.