Incorrect transformation with XSLT contaninig <script> tag

RESOLVED DUPLICATE of bug 158457

Status

()

Core
XSLT
RESOLVED DUPLICATE of bug 158457
16 years ago
16 years ago

People

(Reporter: Manko, Assigned: peterv)

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
If XSLT for transformation from XML to HTML contains <script> tag, I see nothing
as result of transformation.

See example. If you remove <script> from XSLT, rendering will be OK.

MSIE 5.01 + MSXML 4.0 also transforms OK with <script>.
(Reporter)

Comment 1

16 years ago
Created attachment 94003 [details]
menu.xml - main XML file
(Reporter)

Comment 2

16 years ago
Created attachment 94004 [details]
menu.xsl - XSLT for menu.xml
(Reporter)

Updated

16 years ago
Attachment #94004 - Attachment description: XSLT for menu.xml → menu.xsl - XSLT for menu.xml

Comment 3

16 years ago
see bug 124372, bug 59912. 

Comment 4

16 years ago
   Reporter: could you please  read  the  Bug  Writing  Guidelines  at
http://www.mozilla.org/quality/bug-writing-guidelines.html to see  the
kinds of information we need in a bug report. Please report back  with
more information (like BuildID and steps to reproduce)  after  reading
those guidelines and consider using  the  Bugzilla  Helper  to  report
future bugs.

   The Helper can be found at
   http://www.mozilla.org/quality/help/bug-form.html
   Thanks for your help in testing Mozilla.
(Reporter)

Comment 5

16 years ago
Sorry, I didn't pointed my build.
Build ID: 2002072104 (Mozilla 1.1b)

Comment 6

16 years ago
Problem confirmed on 2002080404/win98se; I'm afraid it's a regression, because
previous bugs regarding script/XSLT combination are marked fixed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Assignee)

Comment 7

16 years ago
This looks like it might be related to bug 158457. Sicking?
this just happend to me when using xhtml as result rather then html.

Comment 9

16 years ago
For me, a workaround for the test case is to remove the XHTML namespace from the
<html> tag, i.e. change line 5 to simply "<html>".  The same change to my own
XSLT fixes the same problem there.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Comment 10

16 years ago
The error doesent show in the "simpel example" the script tag ist misspelled in
uppercase. Lowercase is mandatory.

Comment 11

16 years ago
<script> is the culprit. Another workaround is to use <SCRIPT> so that
case-sensitiveness causes it not to match in the XML/XHTML situation. This is
the work-around that you see described in bug 158457 comment 8 for the UMSS
(Universal MathML Style Sheet).

*** This bug has been marked as a duplicate of 158457 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.