The default bug view has changed. See this FAQ.

"Edit as New" inserts extra spaces

VERIFIED WORKSFORME

Status

MailNews Core
Composition
VERIFIED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Ivo Jansch, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
If I write a message, then later do an "edit as new" on the message in the sent
folder, one extra space is added to each line that begins with at least one space.

I'm using: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606, but
I noticed it on older versions too.

Steps to reproduce:

1. compose a msg with the following body:

test
 test
test

2. Send the message to yourself
3. Either do an 'Edit as New' on the received msg, or on the sent message in the
   'Sent' folder.
4. The body in the composer now contains:

test
  test
test

If you send it again, then perform another edit as new, it will contain 3
spaces, etc..

Tried to find duplicates of this bug, couldn't find any.

Comment 1

15 years ago
Confirming this bug ! Weird !

I seen it with trunk build 2002080404 - WinXP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 2

15 years ago
Akkana--is this a problem something Tanu should investigate or is mail doing
something specific (that you know of)

JFD--This sounds like a duplicate of other bugs with summaries of: Edit as New

Comment 3

15 years ago
This bug also shows up when forwarding a message containing lines beginning with
one or more spaces. This using Mozilla 1.2.1 on Windows 2000.

Comment 4

14 years ago
This bug also shows up whenever I write a new message, and let at least one
space at the beginning of a new line : each line with at least one heading space
will have one additional space once transmitted.

I saw this bug in all the versions of Mozilla and Netscape I tried, i.e.
- Mozilla 1.0
- Mozilla 1.2.1
- Netscape 7.0
- Netscape 7.01

Please note that I hate HTML in mail and news, and I want to see a plain text
mail exactly as it is, thus I unckecked "Compose messages in HTML format", and I
have the following lines in my user.js :

user_pref("mail.quoted_graphical", false); 
user_pref("mail.quoteasblock", false);
user_pref("mailnews.display.disable_format_flowed_support", true);

P.S.: see also bug 153807.

Comment 5

14 years ago
Another irritating "feature" of this bug is that when the sent mail
is seen within Mozilla Mail itself, one doesn't see the problem - only
if one does a "View Source" on the message does one see the problem!

This bug makes it impossible to send source patches (as diffs)
using Mozilla Mail!

Comment 6

14 years ago
Oh ! Maybe it's the reason why there are so few votes for this bug.
Probably we should open a new bug for showing all mails in plain text by
default, without any "rich text" or "html"!

With my user preferences, I always see the bug, without any View Source:

user_pref("mail.quoted_graphical", false); 
user_pref("mail.quoteasblock", false);
user_pref("mailnews.display.disable_format_flowed_support", true);


Comment 7

14 years ago
If this is a format=flowed problem, you're missing one important pref:
user_pref("mailnews.send_plaintext_flowed", false);
See bug 168420 for more info, in particular the f=f FAQ which is attached to
that bug.  Also take a look at the dependency tree for that bug, since this may
be a dup  of a bug that's already had lots of discussion/flameage.

Comment 8

14 years ago
Merci beaucoup !

This was indeed a format=flowed problem. I suggest that, after checking, bug
161091 and bug 153807 be marked as dups of one f=f bug.

Comment 9

14 years ago
Could be a dupe of bug 155622. Please check and mark accordingly.

pi

Comment 10

14 years ago
*** Bug 207616 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
Looks like it has been fixed in the RC3 of mozilla 1.4.

Comment 12

14 years ago
I agree, this bug appears to have been fixed in 1.4.  Reporter (Ivo), feel free 
to reopen this if you're still having problems.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

14 years ago
Indeed, it works now. Although I am not the QA for this bug, I verified that it
works now, so I'm setting it to 'verified' (I hope that's not against policy)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.