Closed Bug 16110 Opened 20 years ago Closed 20 years ago

[Urg. request] Pls rewrite titledbutton to contain 2 child nodes...

Categories

(Core :: XUL, enhancement, P3)

x86
Other
enhancement

Tracking

()

VERIFIED DUPLICATE of bug 16429

People

(Reporter: german, Assigned: shaver)

Details

we need to control the text of titledbutton using style attributes in order to
have toolbar buttons (and other) being switched from Image/Text-only. right now
this is cumbersome to do at best since the value is hard-coded into XUL. Upon
removing it, the text title still gets broadcasted into the button, and
removing that will also remove this from a menu.
The cleanest solution would be (since titledbuttons are used universally not
just in buttons) to make 2 independent child elements inside a titledbutton:
- a text label that knows how to crop left, right and middle
- an image
that way (much like splitters) designer can (but don't have to) specify
behavior, alignment and appearance with much greater precision.
Severity: normal → major
Assignee: trudelle → evaughan
reassigning to evaughan for consideration and triage
BTW, the only reasonable severity for this would be "Enhancement"
Severity: major → enhancement
sorry! (setting to [Enhancement])
It is blocking us though from implementing the planned look and feel and a few
other FE features.
Status: NEW → ASSIGNED
Target Milestone: M14
This will require some work. Titled button currenly contain no child nodes so
they would have to become a container and learn to manage their children. I
would guess this would be at least a week to implement and because titledbuttons
are used everywhere. There should also be lots of testing to make sure nothing
is broken by it.
Assignee: evaughan → shaver
Status: ASSIGNED → NEW
shaver is deep into this, but this really isn't dogfood, so it's going to have
to wait a while.

*** This bug has been marked as a duplicate of 16429 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.