select tag not opening inside a DIV with style overflow

VERIFIED DUPLICATE of bug 96756

Status

()

--
major
VERIFIED DUPLICATE of bug 96756
16 years ago
16 years ago

People

(Reporter: colletodo, Assigned: rods)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
SELECT tag (drop down select box) does not open when inside a DIV inside a TABLE
or inside a TABLE inside a DIV when the DIV has a STYLE="overflow:auto;"
parameter that forces the table to scroll after being drawn.
It works ok in MS IE 5.5 and 6.
I think it is major bug, because I am unable to use select boxes inside resized
tables, which is a needed and standard feature that must work.
Example code:
<table width="100%" height="100%">
<tr><td width="100%">
<div style="width:200px;height:100px; overflow:auto;">
<table height="100%"> 
<tr><td>
<select name="no"><option>lala</option>
<option>lala1</option>
<option>lala2</option>
<option>lala3</option>
</select>
<select name="no"><option>lala</option>
<option>lala1</option>
<option>lala2</option>
<option>lala3</option>
</select>
<select name="no"><option>lala</option>
<option>lala1</option>
<option>lala2</option>
<option>lala3</option>
</select>
<select name="no"><option>lala</option>
<option>lala1</option>
<option>lala2</option>
<option>lala3</option>
</select>
</td></tr>
</table>

You can not open the select boxes to select other than the default value which
makes unusable the table and the page.

Comment 1

16 years ago
Dupe of bug 96756 "SELECT element inside of DIV with "overflow:auto" does not
drop when you click on it."

*** This bug has been marked as a duplicate of 96756 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.