Open Bug 1611056 Opened 4 years ago Updated 1 year ago

Windows are created as white rectangles when Firefox opens, resulting in a white flash when in dark mode

Categories

(Core :: DOM: Core & HTML, defect)

72 Branch
Unspecified
Windows 10
defect

Tracking

()

REOPENED

People

(Reporter: yoasif, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Please dupe if already reported.

Reported on: https://www.reddit.com/r/firefox/comments/esf283/is_there_a_way_to_remove_this_white_flash_of/

The post has 235 net upvotes with 98% approval.

I am able to reproduce.

Steps to reproduce:

  1. Enable dark mode in Windows 10
  2. Launch Firefox -- or better yet, do a session restore with many windows

What happens:

Window is initially drawn as a white rectangle, then gets drawn in as a dark Firefox window.

Expected result:

Firefox shouldn't show anything (white rectangle) before a fully themed Firefox can be shown.

FWIW, I see the same issue in Chromium 81.

I do not see this issue in GNOME on Linux or in macOS, so I filed this under win32.

Summary: Windows are created white before Firefox draws itself, resulting in a white flash when in dark mode → Windows are created as white rectangles before Firefox draws itself, resulting in a white flash when in dark mode
See Also: → 1408122
Summary: Windows are created as white rectangles before Firefox draws itself, resulting in a white flash when in dark mode → Windows are created as white rectangles whenFirefox draws itself, resulting in a white flash when in dark mode
Summary: Windows are created as white rectangles whenFirefox draws itself, resulting in a white flash when in dark mode → Windows are created as white rectangles when Firefox opens, resulting in a white flash when in dark mode

This appears to be a dupe of bug 1408122 which a contributor is working on.

Status: NEW → RESOLVED
Closed: 4 years ago
Component: Widget: Win32 → Theme
Product: Core → Firefox
Resolution: --- → DUPLICATE
Component: Theme → DOM: Core & HTML
Product: Firefox → Core
Attached video 2020-05-23 03-17-46.mkv

I don't think this is a dupe of bug 1408122. I hadn't noticed this before because I don't use Windows as my primary OS, but I continue to see this on my Windows install. I also continue to see it in Chrome, FWIW.

Here is a screen recording - I opened both Chrome and Firefox Nightly, and you can see white flashes as windows open.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Blocks: dark-mode
See Also: → 1750085
See Also: → 1758065
Severity: normal → S3
You need to log in before you can comment on or make changes to this bug.