Closed Bug 1611326 Opened 1 year ago Closed 1 year ago

Default to py3_action for all GeneratedFiles

Categories

(Firefox Build System :: General, task)

task
Not set
normal

Tracking

(firefox75 fixed)

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: mshal, Assigned: mshal)

References

Details

Attachments

(1 file)

In order to run GeneratedFile scripts under python3, we need a way to select which scripts will run under py3 instead of py2. Since the end result will be all scripts running in python3, that should be the default. All existing scripts can be annotated to run under py2, and the converted individually.

GENERATED_FILES now defaults to python3 unless py2=True is specified as
an argument. All existing GENERATED_FILES scripts and GeneratedFile
templates have the py2=True attribute added, so this patch should
effectively be a no-op.

Going forward, individual scripts can be converted to python3 and their
corresponding py2=True attribute can be deleted. In effect, this patch
will be backed out in pieces until all scripts run in python3, at which
point the py2 attribute itself can be removed.

Pushed by mshal@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7fefed11f117
Default to py3_action, and add a py2 attribute to GENERATED_FILES; r=firefox-build-system-reviewers,rstewart

Bug 1599581 landed after I wrote the patch, which added a new GENERATED_FILES script that needs to run in python2 for now. After I rebased and double-checked the patch with try -p all this morning, the 'Android 4.0 API16+ GeckoView multi-arch fat AAR opt' build did not run but is apparently a tier-1 build platform.

Flags: needinfo?(mshal)
Pushed by mshal@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/77e54e76848a
Default to py3_action, and add a py2 attribute to GENERATED_FILES; r=firefox-build-system-reviewers,rstewart
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/6a58c483b49d
set charsetalias to use py2. rs=bustage-fix for Thunderbird

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Backout by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/382c4128a132
Backed out changeset 6a58c483b49d since bug 1611326 backout from mozilla-central mid-aired the c-c landing

FYI, bug 1615589 landed ar to the locales to run on try and autoland, and should catch the unicode problems on locale metadata early now.

It looks like the issue was actually caused by bug 1613263, so I'll try to re-land. Feel free to ping me if something looks off again.

Flags: needinfo?(mshal)
Pushed by mshal@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5804c68ea337
Default to py3_action, and add a py2 attribute to GENERATED_FILES; r=firefox-build-system-reviewers,rstewart
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/04aeda66afee
Port bug 1611326 - Add py2 attribute when using props2arrays.py. rs=bustage-fix
You need to log in before you can comment on or make changes to this bug.