Yahoo Java Chat applet only displays as a small box

RESOLVED DUPLICATE of bug 160800

Status

RESOLVED DUPLICATE of bug 160800
17 years ago
4 years ago

People

(Reporter: ncmacasl, Assigned: arun)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

Yahoo Java Chat applet (in Yahoo!Groups) only displays as a small box making it
useless -- should be almost full width of screen and 1/3 length

Reproducible: Always
Steps to Reproduce:
1.Go To Groups.yahoo.com, and select any group, join the group, click on   
"Chat" 
2. Chat applet loads, but is a small screen.

applet works fine in Chat.yahoo.com

Actual Results:  Chat applet loads, but is a small screen.

Expected Results:  should like like it does in Chat.yahoo.com  Also Netscape 4.x
loads it (YahooGroups!Chat) just fine!!

Comment 1

17 years ago
do you have to have a yahoo account to use this chat thingie?
anyway, can you provide a direct url that shows the problem and/or a testcase?
(save page and attach it to the bug if that works)
Summary: Yahoo Java Chat applet only displays as a small box → Yahoo Java Chat applet only displays as a small box

Comment 2

17 years ago
I see this for the <applet> tag on a yahoo chat group.

<applet mayscript codebase="http://cs8.chat.sc5.yahoo.com/c174/" 
        code=y.ch.0 archive="chat.jar" name=chat 
        width="&{innerWidth-160};" height="&{innerHeight-200};">

and noting the 4.x'ish |width="&{innerWidth-160};"|. So, the question is 
whether we support that syntax. If not, then -> Evang.
Assignee: hewitt → beppe
Status: UNCONFIRMED → NEW
Component: JavaScript Console → Plug-ins
Ever confirmed: true
QA Contact: jrgm → shrir

Comment 3

17 years ago
hmm, I an honestly say, I have never seen an applet width and height defined
like that before - is that really supposed to work?

Arun/Shrir -- have you ever seen this type of coding before?

Comment 4

17 years ago
*no*

Comment 5

17 years ago
It's an obscure syntax related to 'javascript style sheets', I seem to recall. I 
can't find a precise reference for it. The closest match is this: 
http://developer.netscape.com/docs/manuals/communicator/dynhtml/layers32.htm#1038571
I don't think this has been "grandfathered" in general (nor would I expect it to
be).

Comment 6

17 years ago
Well it certainly is not inline with HTML coding standards. I would suspect that
this would render appropriately if it were coded in respect to the W3C coding
practices.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 7

17 years ago
-> evang

No, I don't think we should fix this (be backward compatible on this obscure 
feature). But if yahoo is using this in high profile quantities, then we do 
need to do something about it.
Status: RESOLVED → REOPENED
Component: Plug-ins → US Ecommerce
Product: Browser → Tech Evangelism
Resolution: WONTFIX → ---
Version: other → unspecified

Comment 8

17 years ago
-> evang
Assignee: beppe → aruner
Status: REOPENED → NEW
QA Contact: shrir → bclary

Comment 9

17 years ago
*** Bug 161210 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
*** Bug 142076 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
There was some interesting discussion with relation to this bug in bug 142076

Updated

17 years ago
Blocks: 121228

Comment 12

17 years ago

*** This bug has been marked as a duplicate of 160800 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
No longer blocks: 121228

Comment 13

16 years ago
tech evang june 2003 reorg
Component: US Ecommerce → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.