Closed Bug 1611466 Opened 2 years ago Closed 2 years ago

Appending "&test_paths=foo" to the URL will only filter jobs if you do a full reload

Categories

(Tree Management :: Treeherder: Frontend, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: armenzg, Unassigned)

Details

(Keywords: good-first-bug, Whiteboard: [lang:js])

If you append to the URL "&test_paths=foo" it will not filter the jobs that have executed such test paths. Reloading the URL with "&test_paths=foo" will show it correctly.

Steps to reproduce:

Expected results:

  • A lot of jobs are shown that have executed tests with devtools in their path

Actual results:

  • No jobs are shown

Work around

  • Reload the URL
Summary: Appending if you append to the URL "&test_paths=foo" will not apply properly → Appending "&test_paths=foo" to the URL will only filter jobs if you do a full reload

This is an issue existing with the whole app actually and not with this component. Neither is any request being served on clicking it nor is the state of the component changing. I am looking into the cause of this. Any help will be highly thankful.

I don't know how to solve this without working on it.

The problem is probably rooted on a disconnect on how we handle URL parameter changes and to trigger changes associated to filtering.

I would first simply look to find out if URL parameter changes by modifying the URL and pressing enter are even noticed. Maybe there's some info on stackoverflow or the react-router documentation.

I hope that helps!

Just checked it now, the issue exists no longer .
Appends &test_paths=foo to https://treeherder.mozilla.org/#/jobs?repo=mozilla-central gives the results we expect

Thanks for checking!

This was probably a side effect of a bug that I fixed last week:
https://github.com/mozilla/treeherder/commit/013c949c4037c16d91d774394b0995c5353f3a67

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.