crash attempting to open page

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED INVALID
16 years ago
7 years ago

People

(Reporter: chance, Assigned: Joshua Xia)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0sp2; en-US; rv:1.1b)
Gecko/20020721
BuildID:    2002072104




page loads correctly with IE5.5sp2 on same machine

Reproducible: Always
Steps to Reproduce:
1.enter link in location bar
2.press enter/return
3.

Actual Results:  
dr. watson paid me a visit
dialog box with 'Memory address conflict' appeared
Talkback started up

talkback id:  TB9006340Q
Reporter: 
Which JRE Do you use ?
Do you also crash if you disable Java ?

if not : 
Can you upgrade to JRE 1.4 if you use JRE1.3 ?
(http://java.sun.com/j2se/1.4/download.html)

wfm with win2k build 20020803.. and JRE1.4.1beta
Keywords: crash
also wfm on Linux (2002073022)
(Reporter)

Comment 3

16 years ago
crash does not happen with Java disabled

I am running JRE 1.4.0_01, the latest official release

Comment 4

16 years ago
cf bug 140931...

Here's the stack for 
Incident # 9006340
--------------------
Product ID MozillaTrunk
Build ID 2002072104
Operating System Windows NT 5.0 build 2195
URL visited http://aurora1.webarts.bc.ca:88/jOggPlayer/html/jOggPlayerOverview.jsp
User Comments this page will produce repeated crashes works fine from IE5.5sp2

Stack Trace
jpins32.dll + 0x97b9 (0x01be97b9)
jsj_ConnectToJavaVM [c:/builds/seamonkey/mozilla/js/src/liveconnect/jsj.c, line 483]
JSJ_AttachCurrentThreadToJava
[c:/builds/seamonkey/mozilla/js/src/liveconnect/jsj.c, line 704]
map_js_context_to_jsj_thread_impl
[c:/builds/seamonkey/mozilla/modules/oji/src/lcglue.cpp, line 211]
jsj_EnterJava [c:/builds/seamonkey/mozilla/js/src/liveconnect/jsj_utils.c, line 459]
JavaPackage_resolve
[c:/builds/seamonkey/mozilla/js/src/liveconnect/jsj_JavaPackage.c, line 168]
js_LookupProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2295]
js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2456]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2576]
js_Execute [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 970]
JS_EvaluateUCScriptForPrincipals [c:/builds/seamonkey/mozilla/js/src/jsapi.c,
line 3381]
nsJSContext::EvaluateString
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 703]
nsScriptLoader::EvaluateScript
[c:/builds/seamonkey/mozilla/content/base/src/nsScriptLoader.cpp, line 570]
nsScriptLoader::ProcessRequest
[c:/builds/seamonkey/mozilla/content/base/src/nsScriptLoader.cpp, line 478]
nsScriptLoader::ProcessScriptElement
[c:/builds/seamonkey/mozilla/content/base/src/nsScriptLoader.cpp, line 422]
nsHTMLScriptElement::MaybeProcessScript
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLScriptElement.cpp,
line 427]
nsHTMLScriptElement::SetDocument
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLScriptElement.cpp,
line 198]
nsGenericHTMLContainerElement::AppendChildTo
[c:/builds/seamonkey/mozilla/content/html/content/src/nsGenericHTMLElement.cpp,
line 4081]
HTMLContentSink::ProcessSCRIPTTag
[c:/builds/seamonkey/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 4995]
HTMLContentSink::AddLeaf
[c:/builds/seamonkey/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 3280]
CNavDTD::AddLeaf [c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, line 3799]
CNavDTD::HandleScriptToken
[c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, line 2270]
CNavDTD::OpenContainer [c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp,
line 3444]
CNavDTD::HandleDefaultStartToken
[c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, line 1345]
CNavDTD::HandleStartToken
[c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp, line 1750]
CNavDTD::HandleToken [c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp,
line 911]
CNavDTD::BuildModel [c:/builds/seamonkey/mozilla/htmlparser/src/CNavDTD.cpp,
line 528]
nsParser::BuildModel [c:/builds/seamonkey/mozilla/htmlparser/src/nsParser.cpp,
line 1883]
nsParser::ResumeParse [c:/builds/seamonkey/mozilla/htmlparser/src/nsParser.cpp,
line 1747]
nsParser::ContinueParsing
[c:/builds/seamonkey/mozilla/htmlparser/src/nsParser.cpp, line 1368]
nsParserContinueEvent::HandleEvent
[c:/builds/seamonkey/mozilla/htmlparser/src/nsParser.cpp, line 228]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 597]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 530]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line
1078]
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 452]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1527]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1874]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1892]
WinMainCRTStartup()
KERNEL32.DLL + 0xd326 (0x77e8d326)
-> Liveconnect (if not , please reassign it to Oji)

Assignee: Matti → rogerl
Status: UNCONFIRMED → NEW
Component: Browser-General → Live Connect
Ever confirmed: true
QA Contact: asa → pschwartau

Comment 6

16 years ago
I notice the call to oji/src/lcglue.cpp in the stack.

I remember seeing discussion in OJI recently about this,
so let me reassign there for further triage; cc'ing Patrick.

If the crash is in fact due to standalone LiveConnect code,
please reassign back; thanks -
Assignee: rogerl → joe.chou
Component: Live Connect → OJI
QA Contact: pschwartau → pmac

Comment 7

16 years ago
Reporter, please try the recent official release, JRE 1.4.1fc from
java.sun.com/j2se, and see what happens. 
(Reporter)

Comment 8

16 years ago
web page link is no longer valid so I can't test original test case
;(

Updated

16 years ago
QA Contact: pmac → petersen
(Assignee)

Comment 9

15 years ago
reassign to me
Assignee: joe.chou → joshua.xia

Comment 10

15 years ago
Reporter. Since the URL is not available, I want to close this bug. If you have
a new URL for testing, feel free to reopen it.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

15 years ago
no problem here

I apologize for wasting anybody's time, I didn't realize the site owner was 
going to pull the page so fast.

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.