Closed Bug 1612168 Opened 2 months ago Closed 2 months ago

Use messenger icon files instead of duplicated calendar icon files

Categories

(Thunderbird :: General, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 74.0

People

(Reporter: pmorris, Assigned: pmorris)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

A follow-up on bug 1608610. See comment 107 (https://bugzilla.mozilla.org/show_bug.cgi?id=1608610#c107). "Stop using the chrome/calendar/skin/common/icons/* files in favour of the messenger ones".

Summary: Use messenger skin files instead of duplicated calendar skin files → Use messenger icon files instead of duplicated calendar icon files
Comment on attachment 9123887 [details] [diff] [review]
use-messenger-icons-for-cal-0.patch

Review of attachment 9123887 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/installer/allowed-dupes.mn
@@ -48,5 @@
>  components/calFilter.js
>  chrome/calendar/content/calFilter.js
>  components/calUtils.js
>  chrome/calendar/content/calUtils.js
> -chrome/calendar/skin/common/icons/address.svg

You should check if the files in # mail can also be removed. Normally they are listed because of the duplicates in calendar.
Comment on attachment 9123887 [details] [diff] [review]
use-messenger-icons-for-cal-0.patch

As Richard said, you also should check and take out the references to the mail/ copies of these files in allowed-dupes.mn. R+ with that.
Attachment #9123887 - Flags: review?(geoff) → review+

Good call Richard. I've removed those entries for mail and confirmed it works with this try run:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=c9fb5a205d3e7f8179146fc80a7b332203cb1369

Geoff, I see you marked this as blocking bug 1608610. I was planning on landing it after that. Either way is fine, but after would be easier since I wouldn't have to re-order the patches.

Attachment #9123887 - Attachment is obsolete: true
Attachment #9124110 - Flags: review+

It's just words on a screen, you don't have to obey them.

No longer blocks: 1608610
Depends on: 1608610

Okay, this is rebased so it can land before the patches for bug 1612166 that I'm still working on.

Attachment #9124110 - Attachment is obsolete: true
Attachment #9125147 - Flags: review+

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/bde1bbc31f16
Use messenger icons for calendar where we can. r=darktrojan

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 74.0
You need to log in before you can comment on or make changes to this bug.