Closed Bug 1612279 Opened 3 years ago Closed 3 years ago

Perma [tier 2] Linux condprof firefox IndexError: list index out of range - res = output.strip().split()[-1]

Categories

(Testing :: Condprofile, defect)

Version 3
defect
Not set
normal

Tracking

(firefox74 fixed)

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: malexandru, Assigned: egao)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Since the changes in Bug 1611339 landed the condprof jobs on Linux x64 opt started permafailing on central:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&group_state=expanded&resultStatus=testfailed%2Cbusted%2Cexception%2Csuccess%2Crunnable&fromchange=388a4d04e91159527a69fa1e3d2a91e7155247aa&searchStr=linux%2Cx64%2Copt%2Cconditioned%2Cprofile%2Cbuilder%2Ccondprof-linux64-firefox%2Ccondprof%28firefox%29&tochange=485e623584d63bbaba3a8b8267bb1d6e55c68042&selectedJob=286907843

We added the condprof jobs on autoland to figure this out:
https://treeherder.mozilla.org/#/jobs?repo=autoland&tochange=7cde282c17e5c96dcefde1035dbeaa00b14b0bc8&fromchange=019ae805259f58a086c5358850f3b2c95b04518a&searchStr=linux%2Cx64%2Copt%2Cconditioned%2Cprofile%2Cbuilder%2Ccondprof-linux64-firefox%2Ccondprof%28firefox%29&selectedJob=286943269

Log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=286927573&repo=mozilla-central&lineNumber=199

[task 2020-01-30T06:25:45.449Z] Successfully built pyyaml
[task 2020-01-30T06:25:45.507Z] Installing collected packages: pyyaml
[task 2020-01-30T06:25:45.544Z] Successfully installed pyyaml-5.1.2
[task 2020-01-30T06:25:46.085Z] WARNING: You are using pip version 19.2.3, however version 20.0.2 is available.
[task 2020-01-30T06:25:46.085Z] You should consider upgrading via the 'pip install --upgrade pip' command.
[task 2020-01-30T06:25:46.319Z] [2020-01-30T06:25:46.315072] Verifying Desktop Firefox binary
[task 2020-01-30T06:25:46.319Z] Traceback (most recent call last):
[task 2020-01-30T06:25:46.319Z] File "condprof/runner.py", line 194, in <module>
[task 2020-01-30T06:25:46.319Z] main()
[task 2020-01-30T06:25:46.319Z] File "condprof/runner.py", line 106, in main
[task 2020-01-30T06:25:46.319Z] version = get_version(args.firefox)
[task 2020-01-30T06:25:46.319Z] File "condprof/../condprof/util.py", line 293, in get_version
[task 2020-01-30T06:25:46.319Z] res = output.strip().split()[-1]
[task 2020-01-30T06:25:46.319Z] IndexError: list index out of range
[fetches 2020-01-30T06:25:46.344Z] removing /builds/worker/fetches
[fetches 2020-01-30T06:25:47.064Z] finished
[taskcluster 2020-01-30 06:25:47.608Z] === Task Finished ===
[taskcluster 2020-01-30 06:25:47.735Z] Artifact "public/condprof" not found at "/builds/worker/archive"

Edwin, Tarek, could you please take a look?

Flags: needinfo?(egao)

Looks like it can't find the Firefox binary anymore for some reason... It's unclear to me what was stripped that did this regression.
Edwin, any ideas?

In any case, I am going to improve the code so we get a clearer error message.

Well, this is clearly related to my efforts to trim down the debian10-test docker image from being bloated (~2000MB).
LO
:tarek - I was not aware you have used debian10-test as the basis for condprof. What is the dependency of condprof? Could it be based on ubuntu1804-test image instead, which is more tightly managed than the deb10-test image (which was effectively abandoned)?

The changes in the patch that caused this is https://phabricator.services.mozilla.com/D60945. I don't recall removing anything that is python related, but it seems to fail when the Firefox version is being validated.

I will do a try push to see if the ubuntu1804-test image can stand in for the deb10-test image.

I added https://treeherder.mozilla.org/#/jobs?repo=try&revision=dacc53da7a1b973d37ada6e5a6293d10d0aef623 to see what is the CLI error

but yeah, any ubuntu image with all the python3 toolchain should work. happy to move to it if needed, thanks for the upcoming test/

Using ubuntu1804-test seems to work, and that image is also leaner since I'm still actively working on it. I will put up a patch to switch it over now.

Flags: needinfo?(egao)
Assignee: tarek → egao

Oh sorry, I should have asked if you wanted to use this bug for the switchover before I reassigned the bug to myself.

go for it. thanks!

weird: the old docker works fine on my try..
but happy to use the new one, it's green so r+

Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ec549337f2b
condprof to use ubuntu1804-test image r=tarek
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
You need to log in before you can comment on or make changes to this bug.