Closed Bug 1612621 Opened 2 years ago Closed 2 years ago

Firefox developer Edition has a wrong websocket message time format in Network Tool

Categories

(DevTools :: Netmonitor, defect)

73 Branch
defect
Not set
normal

Tracking

(firefox-esr68 unaffected, firefox72 unaffected, firefox73 verified, firefox74 verified)

VERIFIED FIXED
Firefox 74
Tracking Status
firefox-esr68 --- unaffected
firefox72 --- unaffected
firefox73 --- verified
firefox74 --- verified

People

(Reporter: lin.song.r, Assigned: Harald)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

Attached image TimeFormatCapture.JPG

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

Debug a webpage with a web-socket connection to back-end service.

  • Open debugger and switch to "Network", filter by "WS".
  • Click the web-socket connection and switch to "Messages".

Actual results:

In the "time" column for web-socket messages, the format is strange, like "1/31/2020.051".

Expected results:

The time format should be "11:30:45.051".

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0
20200131213333

Reproducible in beta and nightly, but not release. Harald, please have a look. Bug 1603276 looks like the prime suspect.

Status: UNCONFIRMED → NEW
Component: Untriaged → Netmonitor
Ever confirmed: true
Flags: needinfo?(hkirschner)
Keywords: regression
Product: Firefox → DevTools

Is this the same as bug 1609232?

No, but the solution to this regression could be to use the approach described in bug 1609232.

Flags: needinfo?(hkirschner)
Assignee: nobody → hkirschner
Status: NEW → ASSIGNED
Blocks: 1612965
Duplicate of this bug: 1609232
Pushed by hkirschner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ade9ca7e807b
Fix regressed time localization for WS by removing Intl use r=jdescottes
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74

Comment on attachment 9124133 [details]
Bug 1612621 - Fix regressed time localization for WS by removing Intl use r=honza

Beta/Release Uplift Approval Request

  • User impact if declined: DevTools users will see non-sensical timestamps in WebSocket inspector.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open Network panel and open https://libwebsockets.org/testserver/
    Select WS resource to open the Network sidepanel
    Select the Messages tab in Network panel
    Observe timestamps for each row.

ER: Timestamp should be formatted hh:mm:ss.mmm

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Limited code change that only affects the time column in the WS Inspector.
  • String changes made/needed: None
Attachment #9124133 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9124133 [details]
Bug 1612621 - Fix regressed time localization for WS by removing Intl use r=honza

73 is on release now

Attachment #9124133 - Flags: approval-mozilla-beta? → approval-mozilla-release?

Given the niche feature and impact, I don't think uplifting to release is worth it (I hope this flag correctly captured that).

I'm leaving it on the radar as a ride-along fix in the event of an RC respin (or dot release later) but I agree that it's not a driver in and of itself.

Hello! Reproduced the issue using Firefox 74.0a1 (20200131213333) on Windows 10x64 and STR from comment 8.
The issue is verified fixed with Firefox 74.0a1 (20200204214324) on Windows 10x64, macOS 10.15 and Ubuntu 18.04. The timestamp format is hh:mm:ss.mmm (10:18:18.836).

QA Whiteboard: [qa-triaged]

Comment on attachment 9124133 [details]
Bug 1612621 - Fix regressed time localization for WS by removing Intl use r=honza

Avoids broken timestamps in the WebSocket inspector. Approved for 73.0 RC2.

Attachment #9124133 - Flags: approval-mozilla-release? → approval-mozilla-release+

Verified with 73.0 RC2 (20200207001703) on Windows 10x64, macOS 10.15 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.