Closed Bug 1612705 Opened 2 years ago Closed 1 year ago

Memory use continuously increases when repeatedly reloading www.facebook.com

Categories

(Core :: JavaScript: GC, defect, P3)

72 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1610228

People

(Reporter: vit, Unassigned)

References

Details

(Keywords: memory-footprint)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36

Steps to reproduce:

(Firefox routinely consumes many GB of memory with only a few tabs open. This is only one way to show the issue, Facebook is the most prominent for me.)

Download and install fresh FF - 72.0.2 currently, no extensions.

  1. Open www.facebook.com , no need to login, just front page.
  2. Open new tab with "about:memory" - for me it currently shows 118 MB for that tab.
  3. Switch to Facebook, pres F5 a three times.
  4. After refresh, about:memory shows 213 MB for this tab.
  5. Pressed GC + CC + Minimize memory.
  6. about:memory still shows 166 MB.

Actual results:

The memory is climbing and will get into Gigabytes after a while. My personal best is about 5 GB for a single Facebook tab after a few days of use. Tested on my two Windows devices.

Expected results:

The memory should stay low.

See Also: → 1610228, 1610193

memory-leak key word?

Component: Untriaged → JavaScript: GC
Product: Firefox → Core

This is similar to bug 1608501, and I can reproduce it locally by the same means.

See Also: → 1608501
Summary: Huge memory leak on refresh → Memory use continuously increases when repeatedly reloading www.facebook.com
Priority: -- → P3
Severity: normal → S4
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1610228
You need to log in before you can comment on or make changes to this bug.