window doesn't repaint after opening menus to the right of tools

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Kit Westneat, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

When I click on the menus to the right of Tools (Window, Help, Debug, QA), the
chrome under the menu disappears. I can still see the text, it's just the detail
is gone. The same thing happens to tables when I click on those menus. Clicking
on the Tools menu restores the chrome under that menu, as does clicking on the
location bar, or browsing to a new page
(Reporter)

Comment 1

16 years ago
Created attachment 94161 [details]
screenshot of the problem

Comment 2

16 years ago
wfm 20020805 on linux (BTW: same theme)

Your build isn't very new.. did this just happen in the last days or since you
installed mozilla?
(Reporter)

Comment 3

16 years ago
it's been happening ever since I installed mozilla, I will try a newer build
(Reporter)

Comment 4

16 years ago
Created attachment 94166 [details]
screenshot showing problems with tables

Still has problems in 2002080604

Comment 5

16 years ago
hmm.. mozilla has sometimes problems with some grapiccard drivers.. 

Could you provide some information about your graphic card / driver / revision ?

thanks :)
(Reporter)

Comment 6

16 years ago
Diamond Stealth III S500 series Driver version 8.19.05

S3 Savage4 chipset

More weirdness about it:
If I click on the Window menu, and then move over to the Tools menu before
leaving the menubar, the chrome is fine. 

If I have another window focused above it, and the boundries of that window are
to the right of the URL icon in the location bar, it doesn't paint right when I
move the window off or focus on mozilla. 

Comment 7

16 years ago
looks like you're using a nonstandard theme - does this happen with modern or
classic too?
(Reporter)

Comment 8

16 years ago
yeah, it happens with all the themes. It's probably just a weird quirk of my
system setup, I dunno. It's not a major bug at all, just weird.

Comment 9

15 years ago
reporter (Kit): can you reproduce this bug with a recent build of mozilla (for
example, 1.2beta)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.

Comment 10

15 years ago
no response from reporter for >30 days. resolving WFM.

reporter: if you can reproduce this with a recent build of mozilla, please
reopen this bug. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 11

15 years ago
Kit Westneat:
I think this happens because of leftover/outdated files.
Please see bug 183564 comment 8 for a possible fix
http://bugzilla.mozilla.org/show_bug.cgi?id=183564#c8

Comment 12

15 years ago
I'll try it, but I installed it on a fresh install of Windows XP. Thanks.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.