Browser crashes loading menu applet with large menu size

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: mark-spamx, Assigned: joe.chou)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020621
BuildID:    2002062110

One of the developers and I just finally spent a couple hours nailing this
problem down as far as we can.  This is what we know.  The problem is not with
the page.  This can also fairly easily be proven by turning off java support. 
The applet itself we think is ok.  It loads and runs fine on Windows in IE,
netscape, and mozilla.  However, on linux it crashes the browser.

We went through the menu and tried to find if there was a specific menu entry
causing the problem.  We were able to make it work by deleting a segment of the
menus and proceeded to try and add stuff back in to narrow down the problem. 
Over several iterations though, the problem was always in a different place.

We've come to believe that the problem is with the size of the menu file.  It
seems like if the menu file definition gets over 33k the browser crashes.  It
also doesn't seem to matter what java implementation I use.  It causes it to
crash under blackdown, sun's plugin, and IBM's setup.

While there could be, and probably is, a problem with the java implementation
itself together with this applet the crash behavior is obviously unwanted. 
While Opera is unable to display the applet, it doesn't crash on load either. 
It sounds like there's an exception mozilla isn't catching.  

If we could at least keep the browser from crashing we might be able to get a
decent bug report to indicate what's going on with the java implementation.

Thanks guys.  I look forward to hearing your thoughts on this.  If there are any
other tests anyone would like me to run to further facilitate research into this
problem I'm at your disposal.



Reproducible: Always
Steps to Reproduce:
1.Load the page
2.
3.

Actual Results:  Browser Crashes

Expected Results:  Not crashed.

(Printed when the browser crashes:

INTERNAL ERROR on Browser End: Write failed. sendrequest 

System error?:: Resource temporarily unavailable

I also get a plugin trace file which has this at the end:
                      PLUGIN ERROR 
                      ************ 
Java process: unexpected request 732f5265
(Reporter)

Comment 1

16 years ago
I tried to upload an strace log from executing this, but I can't seem to get the
upload to work.  However, it should be easily reproducable from any
mozilla/linux browser setup.

Comment 2

16 years ago
applet bugs belong to OJI
Assignee: beppe → joe.chou
Component: Plug-ins → OJI
QA Contact: shrir → pmac

Comment 3

16 years ago
Reporter: Could you confirm what versions of JRE you have used and which linux
dist and version?
Can you try with a later build version?
(Reporter)

Comment 4

16 years ago
I'm using the Gentoo distribution, version 1.2
I've confirmed this behaviour with Blackdown's JRE 1.3.3, and 
with IBM's JRE 1.3.3 and with Sun's JRE 1.3.3 and 1.4.x.

I'd be happy to try again with a newer build version.  I'll
pull a copy down and give it a try sometime yet today.
(Reporter)

Comment 5

16 years ago
I just pulled down 1.1Beta (2002072204) and set it up with the plugin from
Blackdown JRE 1.3.3 and checked the site.  It still crashes with the same
error.  I can pull down a nightly if you need me to and try that.

Updated

16 years ago
Keywords: crash, stackwanted
(Reporter)

Comment 6

16 years ago
Created attachment 95108 [details]
strace output from connecting to the site and the resulting crash.

Is this bug not reproducable by anyone else?  It's reproducable on every
machine at my disposal.
(Assignee)

Comment 7

16 years ago
Reporter, could you try it with a recent Sun JRE (i.e., JRE1.4.1rc, available at
java.sun.com/j2se), and see what happens?

Updated

16 years ago
QA Contact: pmac → petersen

Comment 8

16 years ago
I have indepentantly reproduced this bug with mozilla 1.2b along with
j2sdk1.4.1_01 and IBM's jdk.
  (I just stumbled across this bug report while searching for any similar bugs
to the one that was driving me nuts)

It works fine under windows using pretty much every browser you can think of.

Comment 9

16 years ago
WFM on Mozilla v1.2.1 Win98 - Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1)
Gecko/20021130 with JDK 1.4.1_01

Comment 10

16 years ago
WFM, Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030111, Java(TM)
Plug-in 1.4.1-rc-b19.

Comment 11

16 years ago
Still WFM, Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030315, java
1.4.1. One of the applets on the page throws an exception and fails to load:

java.lang.ClassFormatError: advnewsscroll (Bad magic number)
	at java.lang.ClassLoader.defineClass0(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:502)
	at java.security.SecureClassLoader.
           defineClass(SecureClassLoader.java:123)
	at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:148)
	at sun.plugin.security.PluginClassLoader.
           findClass(PluginClassLoader.java:168)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
        [etc]

but the menu applet on the left side loads and runs fine.

Mark, can you reproduce this with a current copy of mozilla?

Travis, do you have a different test case which also demonstrates this problem?

The strace log unfortunately isn't very useful. It's just a trace of the
"mozilla" shell script launching the "mozilla-bin" executable. A trace of
mozilla-bin would be more useful (but much, much larger).

Comment 12

16 years ago
Since over 1 month no answer from the reporter, so closing bug as wfm (as of
last comments).
If the bug exists in newer builds (1.4 final with sun 1.4.2 jre/jdk) then look
for a similar bug or reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.