Closed Bug 1613308 Opened 10 months ago Closed 10 months ago

Cannot drag and drop the padlock icon to make a bookmark when the site specifies an invalid favicon

Categories

(Firefox :: Site Identity, defect, P3)

72 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 75
Tracking Status
firefox-esr68 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- verified
firefox76 --- verified

People

(Reporter: kawakami.ozone, Assigned: johannh)

References

(Regression, )

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Steps to reproduce:

  1. Visit https://blog.lizzie.io/linux-containers-in-500-loc.html .
  2. To make a bookmark, I tried to drag the padlock icon which is at the right side of a shield icon in an address bar.

Actual results:

I could not drag the padlock icon.

Expected results:

I expected that I can drag the padlock icon and drop it into a bookmark bar.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0
20200204214324

I can reproduce the issue on that page, but not elsewhere. Looks like the problem is the invalid icon specified at line 9:
<link rel="icon" href="data:;base64,=">

Browser Console output:

NS_ERROR_NOT_AVAILABLE: browser-siteIdentity.js:1302
    onDragStart chrome://browser/content/browser-siteIdentity.js:1302
    ondragstart chrome://browser/content/browser.xhtml:1
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Untriaged → Site Identity
Ever confirmed: true
Summary: Cannot make a bookmark with drag and drop → Cannot drag and drop the padlock icon to make a bookmark
Summary: Cannot drag and drop the padlock icon to make a bookmark → Cannot drag and drop the padlock icon to make a bookmark when the site specifies an invalid favicon

:ettseng, can anybody look at this in the absence of :nhnt11 ? Thank you!

Flags: needinfo?(ettseng)

Hi Johann, could you investigate this issue?

Flags: needinfo?(ettseng) → needinfo?(jhofmann)
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Priority: -- → P3
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a8b6e6d2273
Catch errors drawing the favicon when dragging from the identity block. r=ewright
Duplicate of this bug: 1617124
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75

Guessing this can ride the trains to 75.

Flags: qe-verify+

I managed to reproduce the issue on Windows 10 x64 using an older version of Nightly 2020-02-05.
I verified the fix on latest Nightly 76.0a1 and beta 75.0b3 using Windows 10 x64, macOS 10.15 and Ubuntu 16.04 x64. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.